summaryrefslogtreecommitdiff
path: root/net-libs/grpc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
commitdd762ff83c330186ee2ede002e08b2f780cddd51 (patch)
tree63198edcc3ad5df8e2566c28ff9bd8af50cc2174 /net-libs/grpc/files
parent51af5f0eb4cddbe6aa7953717873691d77aae9ff (diff)
gentoo resync : 14.07.2019
Diffstat (limited to 'net-libs/grpc/files')
-rw-r--r--net-libs/grpc/files/1.22.0-cxx_arg_list_too_long_forloop.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/grpc/files/1.22.0-cxx_arg_list_too_long_forloop.patch b/net-libs/grpc/files/1.22.0-cxx_arg_list_too_long_forloop.patch
new file mode 100644
index 000000000000..974d6fcc4351
--- /dev/null
+++ b/net-libs/grpc/files/1.22.0-cxx_arg_list_too_long_forloop.patch
@@ -0,0 +1,44 @@
+--- a/Makefile 2018-06-26 11:07:45.948160976 +0200
++++ b/Makefile 2019-06-26 11:04:25.798966336 +0200
+@@ -2820,13 +2820,15 @@
+
+ install-headers_c:
+ $(E) "[INSTALL] Installing public C headers"
+- $(Q) $(foreach h, $(PUBLIC_HEADERS_C), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
+- $(Q) $(foreach h, $(PUBLIC_HEADERS_C), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
++ $(Q) for h in $(PUBLIC_HEADERS_C); do \
++ $(INSTALL) -D $$h $(prefix)/$$h ; \
++ done
+
+ install-headers_cxx:
+ $(E) "[INSTALL] Installing public C++ headers"
+- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
+- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
++ $(Q) for h in $(PUBLIC_HEADERS_CXX); do \
++ $(INSTALL) -D $$h $(prefix)/$$h ; \
++ done
+
+ install-static: install-static_c install-static_cxx
+
+--- a/templates/Makefile.template 2019-06-26 12:38:36.777292299 +0200
++++ b/templates/Makefile.template 2019-06-26 12:48:35.668550020 +0200
+@@ -1302,13 +1302,15 @@
+
+ install-headers_c:
+ $(E) "[INSTALL] Installing public C headers"
+- $(Q) $(foreach h, $(PUBLIC_HEADERS_C), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
+- $(Q) $(foreach h, $(PUBLIC_HEADERS_C), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
++ $(Q) for h in $(PUBLIC_HEADERS_C); do \
++ $(INSTALL) -D $$h $(prefix)/$$h ; \
++ done
+
+ install-headers_cxx:
+ $(E) "[INSTALL] Installing public C++ headers"
+- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
+- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
++ $(Q) for h in $(PUBLIC_HEADERS_CXX); do \
++ $(INSTALL) -D $$h $(prefix)/$$h ; \
++ done
+
+ install-static: install-static_c install-static_cxx
+