summaryrefslogtreecommitdiff
path: root/net-libs/gtk-vnc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /net-libs/gtk-vnc
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'net-libs/gtk-vnc')
-rw-r--r--net-libs/gtk-vnc/Manifest1
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-1.3.1-r1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-libs/gtk-vnc/Manifest b/net-libs/gtk-vnc/Manifest
index 66fe457718ad..45828cb0ad24 100644
--- a/net-libs/gtk-vnc/Manifest
+++ b/net-libs/gtk-vnc/Manifest
@@ -1,3 +1,4 @@
DIST gtk-vnc-1.3.1.tar.xz 222204 BLAKE2B 03e51700ae0a477a2762a67ed5906ce5205025b2fb30df5fa75deb99315d2164f22ee0b97d3fc8c23648921cdba4b4a3e22045b2cb8226360ff9f468bef2162f SHA512 01c9af407f913b214814252d7b204822372293ffc5f658aa646936f9f8cdcd77589c127e4d0e893e914c61470d4616e32f7b1fa9bd3739b2a22caef6710953b9
+EBUILD gtk-vnc-1.3.1-r1.ebuild 1724 BLAKE2B d2f455b261b5d2bff2f32b24dbb6c272b8d0aec9baaa1a7522881f3bb05fa139ce54cc870f88aae72354bfd71534f0982e074380c48993e7ded7ca441f977418 SHA512 c67b1f2bfe0223c79805cfc5af28d834b7d97ba053751123a1645ac0f41f098cf794e6b6a99e2d728af30a02579f494ca78de1f01edb164d67f6c31aa25f1ae7
EBUILD gtk-vnc-1.3.1.ebuild 1532 BLAKE2B 43c184586045fd0c94cc6c9afa65d72f03248480d0981d461d8ebe506fd028cc3989ad2aa3a657d87f7d21c760aabe7b404a6a3bd135b71629ca5aa79018891f SHA512 d2988c18516f598c34f52607a6417b4b41836df363622406b700e3cc782b7a445a21b4bbd9d70c81be91b9bb9d1d357a8c4dd0266e1dc862c2d113aa695ec17b
MISC metadata.xml 486 BLAKE2B 1a058ec43b771d40b1ede9d1b5ae379816fe1410cb96eef8a1b87e084d17f5a5aa406335d9a356d7859d747989528135702e1db5d90fec5c5256241ce2e2adc8 SHA512 ec0c63cbe3d07e9229f6b097500fd85a0fc277f8d64c0d8a6590ae8975e230f8250d05d739388d7d4277c38cc425879c538d235d7465ea745fd5b22990bfa945
diff --git a/net-libs/gtk-vnc/gtk-vnc-1.3.1-r1.ebuild b/net-libs/gtk-vnc/gtk-vnc-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..f5ac953e4e80
--- /dev/null
+++ b/net-libs/gtk-vnc/gtk-vnc-1.3.1-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit flag-o-matic gnome.org vala meson python-any-r1 xdg
+
+DESCRIPTION="VNC viewer widget for GTK"
+HOMEPAGE="https://wiki.gnome.org/Projects/gtk-vnc https://gitlab.gnome.org/GNOME/gtk-vnc"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection pulseaudio sasl +vala wayland X"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gdk-pixbuf-2.36.0:2
+ >=dev-libs/libgcrypt-1.8.0:0=
+ >=net-libs/gnutls-3.6.0:0=
+ >=sys-libs/zlib-1.2.11
+ sasl? ( >=dev-libs/cyrus-sasl-2.1.27:2 )
+ >=x11-libs/gtk+-3.24.41-r1:3[introspection?,wayland?,X?]
+ >=x11-libs/cairo-1.15.0
+ >=x11-libs/libX11-1.6.5
+ pulseaudio? ( media-libs/libpulse )
+ introspection? ( >=dev-libs/gobject-introspection-1.56.0:= )
+"
+# Keymap databases code is generated with python3; configure picks up $PYTHON exported from python-any-r1_pkg_setup
+# perl for pod2man
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/perl-5
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+
+ use vala & vala_setup
+}
+
+src_configure() {
+ # defang automagic dependencies, bug #927952
+ use wayland || append-cflags -DGENTOO_GTK_HIDE_WAYLAND
+ use X || append-cflags -DGENTOO_GTK_HIDE_X11
+
+ local emesonargs=(
+ $(meson_feature introspection)
+ $(meson_feature pulseaudio)
+ $(meson_feature sasl)
+ -Dwith-coroutine=auto # gthread on windows, libc ucontext elsewhere; neither has extra deps
+ $(meson_feature vala with-vala)
+ )
+ meson_src_configure
+}