summaryrefslogtreecommitdiff
path: root/net-libs/gupnp-av
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-16 05:29:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-16 05:29:50 +0000
commitf174ed40d3cca6ab6b3bb718e8b5fccca6b04b3f (patch)
treed5b82bd892cb75d60b0adf4c44305caa9f3fce7a /net-libs/gupnp-av
parent02f2811de683662c5c6f5f120de6b59898ed6b98 (diff)
gentoo auto-resync : 16:01:2024 - 05:29:50
Diffstat (limited to 'net-libs/gupnp-av')
-rw-r--r--net-libs/gupnp-av/Manifest2
-rw-r--r--net-libs/gupnp-av/files/gupnp-av-0.14.1-libxml2-2.12.patch75
-rw-r--r--net-libs/gupnp-av/gupnp-av-0.14.1-r2.ebuild51
3 files changed, 128 insertions, 0 deletions
diff --git a/net-libs/gupnp-av/Manifest b/net-libs/gupnp-av/Manifest
index b50a418c6825..bfa4bbd99df4 100644
--- a/net-libs/gupnp-av/Manifest
+++ b/net-libs/gupnp-av/Manifest
@@ -1,3 +1,5 @@
+AUX gupnp-av-0.14.1-libxml2-2.12.patch 2737 BLAKE2B 011c6665ba1b601582ec7d915ab49df774bf7c04c86daeece7d14fe0c6fcfbb27e25089ecebdafacde64ca7d842154bfe715003ee747af7a78abdeed73cbb894 SHA512 7619cad3fb0cb8c01da550b63514d1bd9e99ef3f785998c85650d0e9bd3e8356b7600579c078b60d43ae8285e6c47187bd7a44b104a4eb737451a6cb4d8e4d5d
DIST gupnp-av-0.14.1.tar.xz 93484 BLAKE2B 5e4c070bc7f0dd1a1b67f58fb178ee575df5f9f3920c8c40f8975ac79c61f707df39a243d4783ff79f691dd42553c3a6eb89715be79bb7683910785afdd83b19 SHA512 b17b38c32fe068b0b74a7ee357be5f3a0df3320fd04338b5f6b04231c601d6cc57d2770c6e6ca42ded5e1be28a6b2746d16417eb322889ffe6a975ec58205655
EBUILD gupnp-av-0.14.1-r1.ebuild 1118 BLAKE2B d6333de48752053b76a82c157ffb271c550193b8e7635d3ccca86a5fcf9bfd6f3f781be543a4b9d1f8cad45e9af1663ce62a04916b3baa8b05bf845323dcca64 SHA512 fc8058b54778966266d50bf474fdfe6d9859e15bf44316abefac6bcf262bf401be32585938fc86c36435b163258de426182f69bffdf3b56218b6e59a18c96e36
+EBUILD gupnp-av-0.14.1-r2.ebuild 1180 BLAKE2B 87e3ca126dd7dcd271e39b3748c0e44c4350bd7249675150e473a1124f6a36d68d677f61ee31bfcf2fe571f75825d8f32cae7784705cf42ad10f9ff330baa860 SHA512 428fdbb1796a49780c0ee95624b1e9a3b18a1c971e61d0a4ce936ca837bb8e1867cbdfca8fb8d39ae422f1c7e32b1cb35aede3853429061a14731c79759249a2
MISC metadata.xml 349 BLAKE2B 50eaa08612bc8686246b4065afe457ac661b806ab6b59cf415fc1c7bdac3603725895c5d3111cbace154061bfcf464e1a3fec8397d5c450fd218e70c4c287484 SHA512 8209c087e777641d5a6e5368a94757cc05088f2f8a54814ecccbdffd9ecb4b2714c0ac13f0374aee339c686c0bb4dc2d03c82b937b9beae0467eb2d82d714988
diff --git a/net-libs/gupnp-av/files/gupnp-av-0.14.1-libxml2-2.12.patch b/net-libs/gupnp-av/files/gupnp-av-0.14.1-libxml2-2.12.patch
new file mode 100644
index 000000000000..c62ed29fe577
--- /dev/null
+++ b/net-libs/gupnp-av/files/gupnp-av-0.14.1-libxml2-2.12.patch
@@ -0,0 +1,75 @@
+https://bugs.gentoo.org/917532
+https://gitlab.gnome.org/GNOME/gupnp-av/-/commit/9557768121d54fdcedabe7544863515d6a813354
+https://gitlab.gnome.org/GNOME/gupnp-av/-/commit/1e10a41fcef6ae0d3e89958db89bc22398f3b4f1
+
+From 9557768121d54fdcedabe7544863515d6a813354 Mon Sep 17 00:00:00 2001
+From: Jens Georg <mail@jensge.org>
+Date: Thu, 3 Aug 2023 23:52:43 +0200
+Subject: [PATCH] Remove deprecates xmlRecoverMemory
+
+Cannot currently remove xmlSchemaValidateStream as validateDoc fails to
+accept the XSD
+--- a/libgupnp-av/gupnp-didl-lite-parser.c
++++ b/libgupnp-av/gupnp-didl-lite-parser.c
+@@ -230,12 +230,17 @@ gupnp_didl_lite_parser_parse_didl_recursive (GUPnPDIDLLiteParser *parser,
+ GUPnPAVXMLDoc *xml_doc = NULL;
+ gboolean result;
+
+- doc = xmlRecoverMemory (didl, strlen (didl));
++ doc = xmlReadMemory (didl,
++ strlen (didl),
++ NULL,
++ NULL,
++ XML_PARSE_NONET | XML_PARSE_RECOVER);
+ if (doc == NULL) {
+ g_set_error (error,
+ G_MARKUP_ERROR,
+ G_MARKUP_ERROR_PARSE,
+- "Could not parse DIDL-Lite XML:\n%s", didl);
++ "Could not parse DIDL-Lite XML:\n%s",
++ didl);
+
+ return FALSE;
+ }
+--- a/libgupnp-av/gupnp-feature-list-parser.c
++++ b/libgupnp-av/gupnp-feature-list-parser.c
+@@ -114,12 +114,17 @@ gupnp_feature_list_parser_parse_text
+ xmlNode *element;
+ GList *feature_list = NULL;
+
+- doc = xmlRecoverMemory (text, strlen (text));
++ doc = xmlReadMemory (text,
++ strlen (text),
++ NULL,
++ NULL,
++ XML_PARSE_NONET | XML_PARSE_RECOVER);
+ if (doc == NULL) {
+ g_set_error (error,
+ G_MARKUP_ERROR,
+ G_MARKUP_ERROR_PARSE,
+- "Could not parse FeatureList XML:\n%s", text);
++ "Could not parse FeatureList XML:\n%s",
++ text);
+
+ return NULL;
+ }
+--
+GitLab
+
+From 1e10a41fcef6ae0d3e89958db89bc22398f3b4f1 Mon Sep 17 00:00:00 2001
+From: Jens Georg <mail@jensge.org>
+Date: Sat, 25 Nov 2023 17:58:49 +0100
+Subject: [PATCH] xml: Fix compatibility with libxml2 2.12.x
+
+--- a/libgupnp-av/xml-util.h
++++ b/libgupnp-av/xml-util.h
+@@ -16,6 +16,7 @@
+
+ #include <glib.h>
+ #include <libxml/tree.h>
++#include <libxml/parser.h>
+ #include <stdarg.h>
+ #include <glib-object.h>
+
+--
+GitLab
diff --git a/net-libs/gupnp-av/gupnp-av-0.14.1-r2.ebuild b/net-libs/gupnp-av/gupnp-av-0.14.1-r2.ebuild
new file mode 100644
index 000000000000..a324b8878c7d
--- /dev/null
+++ b/net-libs/gupnp-av/gupnp-av-0.14.1-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala
+
+DESCRIPTION="Utility library aiming to ease the handling UPnP A/V profiles"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP https://gitlab.gnome.org/GNOME/gupnp-av"
+
+LICENSE="LGPL-2"
+SLOT="0/3" # subslot: soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk-doc +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.58:2
+ dev-libs/libxml2
+ introspection? ( >=dev-libs/gobject-introspection-1.36:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? (
+ dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.14.1-libxml2-2.12.patch
+)
+
+src_prepare() {
+ use vala && vala_setup
+ default
+
+ # This makes sense for upstream but not for us downstream, bug #906641.
+ sed -i -e '/-Werror=deprecated-declarations/d' meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}