summaryrefslogtreecommitdiff
path: root/net-libs/http-parser/http-parser-2.9.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-libs/http-parser/http-parser-2.9.4-r1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-libs/http-parser/http-parser-2.9.4-r1.ebuild')
-rw-r--r--net-libs/http-parser/http-parser-2.9.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/http-parser/http-parser-2.9.4-r1.ebuild b/net-libs/http-parser/http-parser-2.9.4-r1.ebuild
new file mode 100644
index 000000000000..34d63a7745e6
--- /dev/null
+++ b/net-libs/http-parser/http-parser-2.9.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs multilib-minimal
+
+DESCRIPTION="HTTP request/response parser for C"
+HOMEPAGE="https://github.com/nodejs/http-parser"
+SRC_URI="https://github.com/nodejs/http-parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+# 2.9.4 restored ABI compatibility with 2.9.0 but since we failed
+# to set subslot in 2.9.3, we want to provoke another rebuild
+SLOT="0/2.9.4"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sparc x86 ~amd64-linux ~x64-macos ~x64-solaris"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-non-x86-test.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC AR
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" CFLAGS_FAST="${CFLAGS}" library
+}
+
+multilib_src_test() {
+ emake CFLAGS_DEBUG="${CFLAGS}" CFLAGS_FAST="${CFLAGS}" test
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+}