summaryrefslogtreecommitdiff
path: root/net-libs/ldns/ldns-1.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-06 11:42:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-06 11:42:16 +0000
commita03b2fe2d845ae950995bf1c5255da420cbd92d2 (patch)
tree7c05b96187cce0c598ea9af9fe03ab294f4df6e5 /net-libs/ldns/ldns-1.8.1.ebuild
parent9e0addc1cf71ebec277b59e38eb3fa30e650cf9f (diff)
gentoo auto-resync : 06:02:2024 - 11:42:15
Diffstat (limited to 'net-libs/ldns/ldns-1.8.1.ebuild')
-rw-r--r--net-libs/ldns/ldns-1.8.1.ebuild87
1 files changed, 0 insertions, 87 deletions
diff --git a/net-libs/ldns/ldns-1.8.1.ebuild b/net-libs/ldns/ldns-1.8.1.ebuild
deleted file mode 100644
index 00759dab1a36..000000000000
--- a/net-libs/ldns/ldns-1.8.1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{9,10} )
-inherit python-single-r1 multilib-minimal
-
-DESCRIPTION="A library with the aim to simplify DNS programming in C"
-HOMEPAGE="https://www.nlnetlabs.nl/projects/ldns/"
-SRC_URI="https://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc examples python static-libs"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-BDEPEND="
- python? ( dev-lang/swig )
- doc? ( app-text/doxygen )
-"
-DEPEND="
- python? ( ${PYTHON_DEPS} )
- >=dev-libs/openssl-1.1.1l-r1:0=[${MULTILIB_USEDEP},static-libs?]
- examples? ( net-libs/libpcap )
-"
-RDEPEND="${DEPEND}
- !<net-dns/ldns-utils-1.8.0-r2
-"
-
-RESTRICT="test" # missing test directory
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/ldns-config
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}/ldns-1.8.1-pkgconfig.patch"
- )
- default
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable static-libs static) \
- $(multilib_native_use_with python pyldns) \
- $(multilib_native_use_with python pyldnsx) \
- --with-ssl="${EPREFIX}"/usr \
- $(multilib_native_with drill) \
- $(multilib_native_use_with examples) \
- --disable-rpath
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi && use doc ; then
- emake doxygen
- fi
-}
-
-multilib_src_install() {
- default
-
- if multilib_is_native_abi && use doc ; then
- dodoc -r doc/html
- fi
-}
-
-multilib_src_install_all() {
- dodoc Changelog README*
-
- find "${D}" -name '*.la' -delete || die
- use python && python_optimize
-
- insinto /usr/share/vim/vimfiles/ftdetect
- doins libdns.vim
-}