summaryrefslogtreecommitdiff
path: root/net-libs/ldns
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
commit7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (patch)
treee514d1b9999d088064bee1e34a3a3c500d6d7a07 /net-libs/ldns
parentd993571e2ee444d08f4e9e90d493ee37338657e3 (diff)
gentoo auto-resync : 15:04:2024 - 12:04:02
Diffstat (limited to 'net-libs/ldns')
-rw-r--r--net-libs/ldns/Manifest1
-rw-r--r--net-libs/ldns/ldns-1.8.3-r3.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/net-libs/ldns/Manifest b/net-libs/ldns/Manifest
index 6a94e675d995..11fe026df7a8 100644
--- a/net-libs/ldns/Manifest
+++ b/net-libs/ldns/Manifest
@@ -5,4 +5,5 @@ AUX ldns-1.8.3-swig-4.2.0.patch 2935 BLAKE2B 15626ba3f3835bc9e3f86a639177eb6ceb8
DIST ldns-1.8.3.tar.gz 1299856 BLAKE2B 2250445da3beec76c96fbb5cbc00f8d6a5bb6ed5867da7f23511d46ac73d6101303eb6ad85def426b7f9287f6a629a95117bcfa6eb46b775d07ed84048162c7f SHA512 c318747bd975ade389d048680b80495fb083b46507d8dcea7d4d42c75823f56a35b438dcc5320803d39583e5a1e515a51686f7f9010c061a6e8199e1a5505ae9
EBUILD ldns-1.8.3-r1.ebuild 1943 BLAKE2B d37692bced21132fb8da0c52219641fe340a10bc8e63c1e756fa04765fb6fa5bc621973f029c3c291bc296daec6e322ea0dc33896e59dd0f324ddbeae6f31b16 SHA512 7a612d4b5a1dbbb833059529905b94ec272f0bde71fe60295ab54a52be37f17909fcaa5e0752de6f5e453ef568c07cda32d4bfa453caaecfad55f9068dc793c5
EBUILD ldns-1.8.3-r2.ebuild 1996 BLAKE2B e5dbca6c36a8a230a51482b1c1b7db3b25d27ab51416fb9350d8d8d61fedbc299289c36b3415c9238e386f16b4fc8ff640367f03554d945bfce9a2fd81eae32f SHA512 976894604aed6d47baabceed8a0185312daa589ce9ec7b433dff899462b181fdc6120c4cef490e03c78ca445cb3ba51d43d1dd92d5c34bb885f23437c6b369b0
+EBUILD ldns-1.8.3-r3.ebuild 1965 BLAKE2B e5dd228cbfbf229580dd4c983541b3cb509bb8d30e0bd3a2c3b5e7c2bde2c71e584350c2f26333c0219c6b021817de93d6b7b23bbe766968fb94c03a3d565d7b SHA512 0bada3ec2b1ddf9d794ffd404b18e665b887cba7780efae3df357590de79831c8b8ded07f54ef4d217971c98810007e94e8325b0e6607ab578817bcee854a77a
MISC metadata.xml 616 BLAKE2B 17f79a6324d889cc626bb3fceef622a45f112587618bad54422503d7a43914c46a03563f5e0b8d9d170e25c2e77666325607e485d421853359cbae13e7f00b34 SHA512 a764ec840b5dc9cc90c5952b93e2e226914c9eaca52f18f0c4f4d7d128bd1b2bc1eea9e699720d37b2c041fb6b01e0b298ac7f000ed72f0a7e0e2dce733febff
diff --git a/net-libs/ldns/ldns-1.8.3-r3.ebuild b/net-libs/ldns/ldns-1.8.3-r3.ebuild
new file mode 100644
index 000000000000..8b6b4d2afbe2
--- /dev/null
+++ b/net-libs/ldns/ldns-1.8.3-r3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit autotools python-single-r1 multilib-minimal
+
+DESCRIPTION="A library with the aim to simplify DNS programming in C"
+HOMEPAGE="https://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="https://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc examples python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test" # missing test directory
+
+BDEPEND="
+ python? ( dev-lang/swig )
+ doc? ( app-text/doxygen )
+"
+DEPEND="
+ python? ( ${PYTHON_DEPS} )
+ >=dev-libs/openssl-1.1.1l-r1:0=[${MULTILIB_USEDEP},static-libs?]
+ examples? ( net-libs/libpcap )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/ldns-config
+)
+
+PATCHES=(
+ "${FILESDIR}/ldns-1.8.1-pkgconfig.patch"
+ "${FILESDIR}/${P}-docs.patch"
+ "${FILESDIR}/${P}-configure-strict.patch"
+ "${FILESDIR}/${PN}-1.8.3-swig-4.2.0.patch"
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Drop after 1.8.3
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_with python pyldns) \
+ $(multilib_native_use_with python pyldnsx) \
+ --with-ssl="${EPREFIX}"/usr \
+ $(multilib_native_with drill) \
+ $(multilib_native_use_with examples) \
+ --disable-rpath
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use doc ; then
+ emake doxygen
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi && use doc ; then
+ dodoc -r doc/html
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc Changelog README*
+
+ find "${D}" -name '*.la' -delete || die
+ use python && python_optimize
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins libdns.vim
+}