summaryrefslogtreecommitdiff
path: root/net-libs/libbloom/libbloom-1.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /net-libs/libbloom/libbloom-1.5-r2.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'net-libs/libbloom/libbloom-1.5-r2.ebuild')
-rw-r--r--net-libs/libbloom/libbloom-1.5-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-libs/libbloom/libbloom-1.5-r2.ebuild b/net-libs/libbloom/libbloom-1.5-r2.ebuild
new file mode 100644
index 000000000000..9be6bd8a03a9
--- /dev/null
+++ b/net-libs/libbloom/libbloom-1.5-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple and small bloom filter implementation in plain C."
+HOMEPAGE="https://github.com/jvirkki/libbloom"
+SRC_URI="https://github.com/jvirkki/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=("${FILESDIR}"/${PN}-1.5-AR.patch)
+
+src_compile() {
+ tc-export AR CC
+ emake BITS=default OPT=
+}
+
+src_install() {
+ doheader bloom.h
+ dolib.so build/${PN}.so*
+}