summaryrefslogtreecommitdiff
path: root/net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild')
-rw-r--r--net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild b/net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild
new file mode 100644
index 000000000000..c6a7e694e720
--- /dev/null
+++ b/net-libs/libbtbb/libbtbb-2020.12.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Library to decode Bluetooth baseband packets"
+HOMEPAGE="https://github.com/greatscottgadgets/libbtbb"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/greatscottgadgets/libbtbb.git"
+ inherit git-r3
+else
+ MY_PV=${PV/\./-}
+ MY_PV=${MY_PV/./-R}
+ SRC_URI="https://github.com/greatscottgadgets/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_PV}
+ KEYWORDS="amd64 arm x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="static-libs"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PYTHON=OFF
+ -DBUILD_STATIC_LIB=$(usex static-libs)
+ )
+ cmake_src_configure
+}