summaryrefslogtreecommitdiff
path: root/net-libs/libesmtp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-libs/libesmtp
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-libs/libesmtp')
-rw-r--r--net-libs/libesmtp/Manifest1
-rw-r--r--net-libs/libesmtp/libesmtp-9999.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/libesmtp/Manifest b/net-libs/libesmtp/Manifest
index 5deabb9abb2a..d80d092198a7 100644
--- a/net-libs/libesmtp/Manifest
+++ b/net-libs/libesmtp/Manifest
@@ -1,4 +1,5 @@
AUX libesmtp-1.0.6-openssl-1.1-api-compatibility.patch 2243 BLAKE2B 03cf78375e04d781c1deb15ec76ba35b2800dd2b739c9ad330cfc9a25c05f59b684a5cbe8e436288a98e84b2ebab2c08abfdfd81e000f9a3c4053411254ab89c SHA512 9c5e9ea6d6b09dd48225edc17a9003ea863d91e06ec3856ce22d89b1b908f1c8bfccb7a1090dc5b1ff26a62c35a48806805115000eba3a478cab632181c905a1
DIST libesmtp-1.0.6.tar.bz2 365506 BLAKE2B 9ce8c9f210e6c41c95bba55a7aec79c176c4582f5dafc1aba4fbf9adb411b75ab89d400ac7a12b7d5d24ede414cb8e2ca306299a2e156515e611d074142cf5e8 SHA512 c122fc5995b76771cce2db58c9e59597cc3a76d273feb6fc26b869f118e91bdf98a5721ee2d1de8175c376af018b5806b0379bbeba2f5da95108916028fd8dda
EBUILD libesmtp-1.0.6-r3.ebuild 1045 BLAKE2B 3d7115c549a9303bec593f21af7c681c8191d9f52da09c5859012393e8f8fa9ae414b7eb24902afd8500ba6ef8ff4703e7ef181b9a54ecaca856d80ca836e881 SHA512 4753d7258f1c11f1bef1ff87437a37bbf2037180a55f6bac502eb2e5e456c6f0523417e0793b7610da94fdd397e482e768aa73a3de2af059b1986808611d289a
+EBUILD libesmtp-9999.ebuild 1013 BLAKE2B b1026503f0cef6187d7205ce432d3012a93db30ac00db42a6d5596169037a716f76beaea9120bb7012dc034ad1eefda565f9b37b5260799c7e32cc09bd035c63 SHA512 25913d9e0a030d29e12e897212966556d8a73d4de17d6a8ced8a8f61be14f4df9155afc4e318a391521b2ece2186cc2ff20ef5a656862358c880052bcec9d171
MISC metadata.xml 245 BLAKE2B 8d60530acac96088463f7357d79430c34c12384bcda5df24a93a92789a40fb34014c14fb73ea1e80f7e96f5afb8e70a4600a651b46322af25c404bea3c75e004 SHA512 8f811f556e1fb3b6c4955a0815435a2b54897133a5a545d05fc3c47a6f8ad2448fcce4644e2f7f3d5b6835fdbfccba521a49a8c11629a89ab53770d6bc620c25
diff --git a/net-libs/libesmtp/libesmtp-9999.ebuild b/net-libs/libesmtp/libesmtp-9999.ebuild
new file mode 100644
index 000000000000..4f34d1424a76
--- /dev/null
+++ b/net-libs/libesmtp/libesmtp-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit meson
+
+DESCRIPTION="lib that implements the client side of the SMTP protocol"
+HOMEPAGE="https://libesmtp.github.io/"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/libesmtp/libESMTP.git"
+else
+ SRC_URI="https://github.com/libesmtp/libESMTP/archive/v${PV/_}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+fi
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+IUSE="libressl ssl static-libs threads"
+
+RDEPEND="
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-1.1.0:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS docs/{bugreport,ChangeLog,faq}.md NEWS Notes README.md TODO )
+
+src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ $(meson_feature ssl tls)
+ $(meson_feature threads pthreads)
+ )
+ meson_src_configure
+}