summaryrefslogtreecommitdiff
path: root/net-libs/libgrss/libgrss-0.7.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
commit7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (patch)
treee514d1b9999d088064bee1e34a3a3c500d6d7a07 /net-libs/libgrss/libgrss-0.7.0-r1.ebuild
parentd993571e2ee444d08f4e9e90d493ee37338657e3 (diff)
gentoo auto-resync : 15:04:2024 - 12:04:02
Diffstat (limited to 'net-libs/libgrss/libgrss-0.7.0-r1.ebuild')
-rw-r--r--net-libs/libgrss/libgrss-0.7.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-libs/libgrss/libgrss-0.7.0-r1.ebuild b/net-libs/libgrss/libgrss-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..2720d499d99a
--- /dev/null
+++ b/net-libs/libgrss/libgrss-0.7.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="Library for easy management of RSS/Atom/Pie feeds"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libgrss"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.42.1:2
+ >=dev-libs/libxml2-2.9.2:2
+ >=net-libs/libsoup-2.48:2.4[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-build/gtk-doc-am-1.10
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure $(use_enable introspection)
+}