summaryrefslogtreecommitdiff
path: root/net-libs/libisds/libisds-0.11.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /net-libs/libisds/libisds-0.11.1.ebuild
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'net-libs/libisds/libisds-0.11.1.ebuild')
-rw-r--r--net-libs/libisds/libisds-0.11.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-libs/libisds/libisds-0.11.1.ebuild b/net-libs/libisds/libisds-0.11.1.ebuild
new file mode 100644
index 000000000000..d9a4859a617a
--- /dev/null
+++ b/net-libs/libisds/libisds-0.11.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Client library for accessing ISDS Soap services"
+HOMEPAGE="http://xpisar.wz.cz/libisds/"
+SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.xz"
+KEYWORDS="~amd64 ~mips ~x86"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="+curl debug doc nls openssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/libxml2
+ curl? ( net-misc/curl[ssl] )
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+ openssl? ( dev-libs/openssl:= )
+ !openssl? (
+ app-crypt/gnupg
+ app-crypt/gpgme
+ dev-libs/libgcrypt:=
+ )"
+DEPEND="${RDEPEND}
+ test? ( net-libs/gnutls )"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-fatalwarnings
+ --disable-static
+ $(use_with curl libcurl)
+ $(use_enable curl curlreauthorizationbug)
+ $(use_enable doc)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable openssl openssl-backend)
+ $(use_enable test)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}