summaryrefslogtreecommitdiff
path: root/net-libs/libntlm/libntlm-1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-libs/libntlm/libntlm-1.6.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-libs/libntlm/libntlm-1.6.ebuild')
-rw-r--r--net-libs/libntlm/libntlm-1.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-libs/libntlm/libntlm-1.6.ebuild b/net-libs/libntlm/libntlm-1.6.ebuild
new file mode 100644
index 000000000000..0c0220891886
--- /dev/null
+++ b/net-libs/libntlm/libntlm-1.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Microsoft's NTLM authentication (libntlm) library"
+HOMEPAGE="http://www.nongnu.org/libntlm/"
+SRC_URI="http://www.nongnu.org/${PN}/releases/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux"
+IUSE="static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}