summaryrefslogtreecommitdiff
path: root/net-libs/libosmocore/libosmocore-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
commit434d713861b70f6c6563d6ee50a8e64f14c970d9 (patch)
treeb72c523c72e764420f835ba9d63d43ffef687dcf /net-libs/libosmocore/libosmocore-9999.ebuild
parentf78108598211053d41752a83e0345441bb9014ae (diff)
gentoo resync : 15.02.2018
Diffstat (limited to 'net-libs/libosmocore/libosmocore-9999.ebuild')
-rw-r--r--net-libs/libosmocore/libosmocore-9999.ebuild31
1 files changed, 15 insertions, 16 deletions
diff --git a/net-libs/libosmocore/libosmocore-9999.ebuild b/net-libs/libosmocore/libosmocore-9999.ebuild
index ea57bb86c30e..fbd3f9ee9b99 100644
--- a/net-libs/libosmocore/libosmocore-9999.ebuild
+++ b/net-libs/libosmocore/libosmocore-9999.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit autotools eutils
+inherit autotools
DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
if [[ ${PV} == 9999* ]]; then
- inherit git-2
+ inherit git-r3
EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
KEYWORDS=""
else
@@ -19,29 +19,28 @@ fi
LICENSE="GPL-2 LGPL-3"
SLOT="0"
-IUSE="embedded pcsc-lite"
+IUSE="pcsc-lite"
+
+RDEPEND="
+ sys-libs/talloc
+ pcsc-lite? ( sys-apps/pcsc-lite )
+"
-RDEPEND="embedded? ( sys-libs/talloc )
- pcsc-lite? ( sys-apps/pcsc-lite )"
DEPEND="${RDEPEND}
- app-doc/doxygen"
+ app-doc/doxygen
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.6.0-automake-1.13.patch" )
src_prepare() {
+ default_src_prepare
# set correct version in pkgconfig files
sed -i "s/UNKNOWN/${PV}/" git-version-gen || die
- epatch "${FILESDIR}"/${PN}-0.6.0-automake-1.13.patch
eautoreconf
}
src_configure() {
econf \
- $(use_enable embedded) \
$(use_enable pcsc-lite pcsc)
}
-
-src_install() {
- default
- # install to correct documentation directory
- mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
-}