summaryrefslogtreecommitdiff
path: root/net-libs/libquotient/libquotient-0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-10 23:43:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-10 23:43:04 +0000
commit113cc6fe7a9adc2baf67f9ef7723db6ed2b24887 (patch)
tree968fd44d403c54949106d2c90a128f529f7ef3d0 /net-libs/libquotient/libquotient-0.7.1.ebuild
parent1fe49f5b3e13481832866b6b1600741bf3a1f024 (diff)
gentoo auto-resync : 10:01:2023 - 23:43:04
Diffstat (limited to 'net-libs/libquotient/libquotient-0.7.1.ebuild')
-rw-r--r--net-libs/libquotient/libquotient-0.7.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libquotient/libquotient-0.7.1.ebuild b/net-libs/libquotient/libquotient-0.7.1.ebuild
new file mode 100644
index 000000000000..4a30091b1f75
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE=""
+
+DEPEND="
+ dev-libs/qtkeychain:=[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.7.0-no-android.patch
+ "${FILESDIR}"/${PN}-0.7.0-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=OFF
+ -DBUILD_TESTING=OFF
+ -DQuotient_ENABLE_E2EE=OFF # TODO: libolm, libqtolm not packaged
+ )
+ cmake_src_configure
+}