summaryrefslogtreecommitdiff
path: root/net-libs/libsignon-glib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /net-libs/libsignon-glib
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'net-libs/libsignon-glib')
-rw-r--r--net-libs/libsignon-glib/Manifest2
-rw-r--r--net-libs/libsignon-glib/libsignon-glib-2.1.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/net-libs/libsignon-glib/Manifest b/net-libs/libsignon-glib/Manifest
index bdc0cbd663f6..b29c9f1021f3 100644
--- a/net-libs/libsignon-glib/Manifest
+++ b/net-libs/libsignon-glib/Manifest
@@ -1,5 +1,7 @@
AUX libsignon-glib-1.12-doc-disable.patch 844 BLAKE2B 600b936552c64473dfce637d60a782526a42858d3b7e3118c78ec442cb6d53e167503407d0bf3ded34024a7065d5fdbf3f487edd7e3fb701d0a009eff158d094 SHA512 690ee30d4e1d6277c0b02720212654d482173a75657da7f72c30f258921cbe790ea2d47d3de9a598be04e4ef55b995118ab5a537ed728c2735445915810f561d
AUX libsignon-glib-1.14-default-opts.patch 1714 BLAKE2B 8c00bcf5b056cd0fe05f58ed5727569cf9b917d6e4e7e11d90bd52ef343f8b26e02f98ab463e5c2a1121ba48f0260896f1301b1446c0f26146a8e2e5d6ce3c05 SHA512 bb27417ff1dc03510fdd1f019b7b8d044a8c281243467dfa7d2fdd8123ef3290a325a7c9a96bd246f37891bd7ac9ce2702b40396ed067dbac4b9e995a89d2430
DIST libsignon-glib-1.14.tar.gz 54019 BLAKE2B 9ffdb96a374ef0848c1b70cb369a533ea826b24856a32b4b454a0fd8982533041fcc88382fdf1eee6857aa36ec8d076885fc769a058e148e91da54dbddaf7125 SHA512 c2277933d6ec2c3288ce510c853da7719116dac15d60c7114fcdcb87d04e7f70390d066938dea6aa0f819fbd70158fb875c5be5684c47fd27c0b6c55e9467a1d
+DIST libsignon-glib-2.1.tar.gz 52440 BLAKE2B edc27f5f09c3f6d05f32ff6b560934dc003072940b44932fd90021511510fb56beaec7f25dd051b3c1d12d10942f292cc906a9fc4b74bb7f2daf8b885f15e644 SHA512 45d8e26263a16b98517cda0fff8e46fb1ffcc4bb833a6364454f120eb9819b48ee04bdb338bf5e9f0b0fe344af5940f35ed56f0765ca3605dead5b3755657dcf
EBUILD libsignon-glib-1.14.ebuild 1702 BLAKE2B 4275605165e5db245631e43d0dec26563e9d0ed04462be541412f42465770d88c2089ff1f997908bc773f1819a234d3e35a851e61eeec51a4f16b655b16ccb79 SHA512 36f714d100f0cae96b5bb67db9062024d542851709c6dfa456e0ce3909b1db7bd0edc858f628809a71ce976dcaab28d0182fba84b01e2f2bb447403c8148d942
+EBUILD libsignon-glib-2.1.ebuild 1820 BLAKE2B 0dc2371faf190328641b2c8a9140dd10558e36bb979145963fe68aa5898e5d6da71d028a288c65bc0504f18af2d5bc6e7ff0a97736ef22b4be9c5be6a6a23cd6 SHA512 8d6ad0d044fc141c1fd2a135a5c6ce3345e61c745bb156ad49bba63781061b93805b0d5489a3dca4d8ada51310cdab763a1d17276e3be0f4785f56fe33388225
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/net-libs/libsignon-glib/libsignon-glib-2.1.ebuild b/net-libs/libsignon-glib/libsignon-glib-2.1.ebuild
new file mode 100644
index 000000000000..43e1df26d947
--- /dev/null
+++ b/net-libs/libsignon-glib/libsignon-glib-2.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit meson python-r1 vala vcs-snapshot
+
+DESCRIPTION="GLib binding for the D-Bus API provided by signond"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/${PN}/-/archive/VERSION_${PV}/${PN}-VERSION_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug doc +introspection python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} introspection )"
+
+RDEPEND="
+ dev-libs/glib:2
+ net-libs/signond
+ introspection? ( dev-libs/gobject-introspection:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ doc? ( dev-util/gtk-doc )
+ test? ( dev-libs/check )
+"
+
+# needs more love
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ vala_src_prepare
+
+ use doc || sed -e "/^subdir('docs')$/d" -i meson.build || die
+
+ cp libsignon-glib/*.xml libsignon-glib/interfaces || die
+}
+
+src_configure() {
+ myconfigure() {
+ local emesonargs=(
+ -Ddebugging=$(usex debug true false)
+ -Dintrospection=$(usex introspection true false)
+ -Dpython=$(usex python true false)
+ -Dtests=$(usex test true false)
+ )
+
+ meson_src_configure
+ }
+
+ if use python; then
+ python_foreach_impl run_in_build_dir myconfigure
+ else
+ myconfigure
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir meson_src_compile
+ else
+ meson_src_compile
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir meson_src_test
+ else
+ meson_src_test
+ fi
+}
+
+src_install() {
+ einstalldocs
+
+ if use python; then
+ python_foreach_impl run_in_build_dir meson_src_install
+ else
+ meson_src_install
+ fi
+}