summaryrefslogtreecommitdiff
path: root/net-libs/libsoup/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /net-libs/libsoup/files
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'net-libs/libsoup/files')
-rw-r--r--net-libs/libsoup/files/2.66.2-meson-ntlm_auth-fix.patch28
-rw-r--r--net-libs/libsoup/files/2.66.2-vala-0.46-compat.patch26
-rw-r--r--net-libs/libsoup/files/disable-apache-tests.patch33
3 files changed, 87 insertions, 0 deletions
diff --git a/net-libs/libsoup/files/2.66.2-meson-ntlm_auth-fix.patch b/net-libs/libsoup/files/2.66.2-meson-ntlm_auth-fix.patch
new file mode 100644
index 000000000000..04c9cccfeec0
--- /dev/null
+++ b/net-libs/libsoup/files/2.66.2-meson-ntlm_auth-fix.patch
@@ -0,0 +1,28 @@
+From ecd64363f82eb9d6cea07674f49c2d2869e5b62b Mon Sep 17 00:00:00 2001
+From: Claudio Saavedra <csaavedra@igalia.com>
+Date: Tue, 20 Aug 2019 16:04:06 +0300
+Subject: [PATCH] NTLM: Fix build with ntlm enabled
+
+Just realized that build with NTLM enabled was broken (!?)
+
+(cherry picked from commit bab0db142d508e92e72970db72cbbce3c13a526a)
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index f0e34cb0..346ed2fd 100644
+--- a/meson.build
++++ b/meson.build
+@@ -271,7 +271,7 @@ if host_machine.system() != 'windows'
+
+ if ntlm_auth.found()
+ add_project_arguments('-DUSE_NTLM_AUTH=1', language : 'c')
+- add_project_arguments('-DNTLM_AUTH=' + ntlm_auth.path(), language : 'c')
++ add_project_arguments('-DNTLM_AUTH="' + ntlm_auth.path() + '"', language : 'c')
+ endif
+ endif
+ endif
+--
+2.20.1
+
diff --git a/net-libs/libsoup/files/2.66.2-vala-0.46-compat.patch b/net-libs/libsoup/files/2.66.2-vala-0.46-compat.patch
new file mode 100644
index 000000000000..ce0e1dc9b620
--- /dev/null
+++ b/net-libs/libsoup/files/2.66.2-vala-0.46-compat.patch
@@ -0,0 +1,26 @@
+From 1c6f47df99cc5b2efe3d629c71c5d85a7871689c Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Tue, 28 May 2019 09:08:35 +0200
+Subject: [PATCH] gir: soup_auth_new is not a constructor
+
+---
+ libsoup/Soup-2.4.metadata | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/libsoup/Soup-2.4.metadata b/libsoup/Soup-2.4.metadata
+index c0056ec8..1f107eda 100644
+--- a/libsoup/Soup-2.4.metadata
++++ b/libsoup/Soup-2.4.metadata
+@@ -18,6 +18,9 @@ ProxyResolver deprecated_since="2.28" replacement="ProxyURIResolver"
+
+ // Report upstream
+ add_* skip=false type="unowned GLib.TimeoutSource"
++Auth
++ // Factory method
++ .new symbol_type="function"
+ AuthDomain
+ .accepts#method name="accepts_authorization"
+ AuthDomainBasic.new skip=false
+--
+2.20.1
+
diff --git a/net-libs/libsoup/files/disable-apache-tests.patch b/net-libs/libsoup/files/disable-apache-tests.patch
new file mode 100644
index 000000000000..e7d306bde971
--- /dev/null
+++ b/net-libs/libsoup/files/disable-apache-tests.patch
@@ -0,0 +1,33 @@
+From 6c9bbf0d91688e831f8f19232e18619bfc57e12e Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Fri, 23 Aug 2019 21:11:57 +0300
+Subject: [PATCH] meson: Force disable apache/php using tests for now
+
+We had them disabled in autotools with a sed. Keep them disabled for now
+in meson port as well. Should be revisited at some point.
+---
+ meson.build | 7 ++-----
+ 1 file changed, 2 insertions(+), 5 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 89837c15..f0e34cb0 100644
+--- a/meson.build
++++ b/meson.build
+@@ -162,12 +162,9 @@ endif
+ #
+ # The summary is that for the configuration parsing we will use the apachectl,
+ # but for running the tests we will use the httpd binary.
+-apachectl = find_program('apachectl', '/sbin/apachectl', '/usr/sbin/apachectl', required : false)
++apachectl = disabler()
+ # This abomination is a result of https://github.com/mesonbuild/meson/issues/1576
+-apache_httpd2 = find_program('httpd2', 'httpd', 'apache2', 'apache',
+- '/sbin/httpd2', '/sbin/httpd', '/sbin/apache2', '/sbin/apache',
+- '/usr/sbin/httpd2', '/usr/sbin/httpd', '/usr/sbin/apache2', '/usr/sbin/apache',
+- required : false)
++apache_httpd2 = disabler()
+ have_apache=false
+ apache_httpd2_version = ''
+ if apache_httpd2.found() and apachectl.found()
+--
+2.20.1
+