summaryrefslogtreecommitdiff
path: root/net-libs/libssh/libssh-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /net-libs/libssh/libssh-9999.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'net-libs/libssh/libssh-9999.ebuild')
-rw-r--r--net-libs/libssh/libssh-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-libs/libssh/libssh-9999.ebuild b/net-libs/libssh/libssh-9999.ebuild
index 7731aab23884..dc04b6aee9da 100644
--- a/net-libs/libssh/libssh-9999.ebuild
+++ b/net-libs/libssh/libssh-9999.ebuild
@@ -23,6 +23,9 @@ IUSE="debug doc examples gcrypt gssapi libressl mbedtls pcap server +sftp static
REQUIRED_USE="?? ( gcrypt mbedtls ) test? ( static-libs )"
+BDEPEND="
+ doc? ( app-doc/doxygen[dot] )
+"
RDEPEND="
!gcrypt? (
!mbedtls? (
@@ -36,7 +39,6 @@ RDEPEND="
zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )
test? ( >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}] )
"
@@ -44,6 +46,8 @@ DOCS=( AUTHORS README ChangeLog )
PATCHES=( "${FILESDIR}/${PN}-0.8.0-tests.patch" )
+RESTRICT+=" !test? ( test )"
+
src_prepare() {
cmake-utils_src_prepare
@@ -77,7 +81,7 @@ multilib_src_configure() {
-DWITH_PCAP="$(usex pcap)"
-DWITH_SERVER="$(usex server)"
-DWITH_SFTP="$(usex sftp)"
- -DWITH_STATIC_LIB="$(usex static-libs)"
+ -DBUILD_SHARED_LIBS="$(usex !static-libs)"
-DUNIT_TESTING="$(usex test)"
-DWITH_ZLIB="$(usex zlib)"
)