summaryrefslogtreecommitdiff
path: root/net-libs/msgraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /net-libs/msgraph
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'net-libs/msgraph')
-rw-r--r--net-libs/msgraph/Manifest3
-rw-r--r--net-libs/msgraph/metadata.xml11
-rw-r--r--net-libs/msgraph/msgraph-0.2.3.ebuild47
3 files changed, 61 insertions, 0 deletions
diff --git a/net-libs/msgraph/Manifest b/net-libs/msgraph/Manifest
new file mode 100644
index 000000000000..af50ac9ad919
--- /dev/null
+++ b/net-libs/msgraph/Manifest
@@ -0,0 +1,3 @@
+DIST msgraph-0.2.3.tar.xz 95904 BLAKE2B 5c0476511784861e1a6e3f3cb4ecaa50ad494b484b8b60f9305aae95539e8d4e9c0e491298d5d1df0031f28a9c472eb6f197acf02a69625e904c4095263b831a SHA512 23a9c24dde6125a7e6fc8a9db61248423a78e2e50a95880a59662d5824fc3f171b2354ab6ae66c77c75fd1737b1d4b19b7a35f8c6fe9ba393c5b116f3c56128f
+EBUILD msgraph-0.2.3.ebuild 1072 BLAKE2B 734df5a279eddf7f5a6eb8659b0411e96f955af8a66d024ff09815d0902940d0cb0b179a5e97010f6d798cec9c1dbdacfa4559da047d8dd6f79a22bdbde178a0 SHA512 cf8f17b66d3444b9f779827bfc0dd8c43caf0f3881cda2e962d7fdff9fd8ce428e3c6b46829031b9d98d4fbcd032746ac7dea6e46180bc752d3bd223ada14755
+MISC metadata.xml 348 BLAKE2B 96a74107d88bee480e104b6a5ba1c60a1f3534a472464d64951aef3b0df4b492b9e55729cb107513433955024d7c5cefdd5a18c376b635730b02eb136a95d133 SHA512 3ee07de0faeb8e726f240919f83ff8e3e6dfb18c186e5d40e581890a222fa4b434d01f831b8207d34ee8631439896d2021b50ec37591c6b7b5001caaa6d14a20
diff --git a/net-libs/msgraph/metadata.xml b/net-libs/msgraph/metadata.xml
new file mode 100644
index 000000000000..6dc85afd66c7
--- /dev/null
+++ b/net-libs/msgraph/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gnome-gitlab">GNOME/msgraph</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-libs/msgraph/msgraph-0.2.3.ebuild b/net-libs/msgraph/msgraph-0.2.3.ebuild
new file mode 100644
index 000000000000..f8d84f7c0d8b
--- /dev/null
+++ b/net-libs/msgraph/msgraph-0.2.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson
+
+DESCRIPTION="GLib-based library for accessing online serive APIs using MS Graph protocol."
+HOMEPAGE="https://gitlab.gnome.org/GNOME/msgraph"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+IUSE="debug gtk-doc +introspection man test"
+REQUIRED_USE="gtk-doc? ( introspection )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.28.0:2
+ dev-libs/json-glib
+ net-libs/rest:1.0
+ net-libs/libsoup:3.0
+ net-libs/gnome-online-accounts:=
+ >=net-libs/uhttpmock-0.11.0:1.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/gdbus-codegen-2.30.0
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ dev-libs/gobject-introspection-common
+"
+BDEPEND="
+ gtk-doc? ( dev-util/gi-docgen )
+ test? ( net-libs/uhttpmock:1.0 )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}