summaryrefslogtreecommitdiff
path: root/net-libs/nghttp2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /net-libs/nghttp2
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'net-libs/nghttp2')
-rw-r--r--net-libs/nghttp2/Manifest2
-rw-r--r--net-libs/nghttp2/nghttp2-1.39.2.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index cc8127a9aa86..8d2134e63783 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,4 +1,6 @@
DIST nghttp2-1.39.1.tar.xz 1634512 BLAKE2B 66444de067200a7dd66f162c22fd258471d336b1ba02f579a675b5d9dfcbf1600fcfb92a37797842a0482bd0f5c850008508d3d41f7afddc47f7c9330fb34b43 SHA512 36558ed03c59086086abbf144ec7c54c60de3fea00a9ea594feea7186a779781cbb66a08c9b34265892dea382b42b875f551e85331cfa0086e357f9b27b919fa
+DIST nghttp2-1.39.2.tar.xz 1635428 BLAKE2B 4569774c33f17d51ac889c385697fcead82106db421399ceb22ad2aafabe64a576445d9272adcf37e2fec47cdd6ac1dc6423efd49012ca7be0aa2087609a0397 SHA512 d8c971543e3e87736dfafebca55e9ecd0644e304c9731edaccba34170205824476595861a439077289b438ad489dd6008dedf2c6b2c111920300329be1b1bf34
EBUILD nghttp2-1.39.1.ebuild 1955 BLAKE2B 60502c5f8505c6b83441dd6f92b1a6b232a5025b96922341ffe3be0b7543ffe95484be0c38b757849432d02d39d749165a24a9b9c4d7148451d5b8da6772d552 SHA512 3075acc15ecb395a3fea2963652bf0bcdbe8678d1061afe728a7f149722d3bc4ffd1042b2e5987b7f69a78d2070be977e1c8407480d5bd29cfc1743530ef9037
+EBUILD nghttp2-1.39.2.ebuild 1958 BLAKE2B 9e77f91fc8d96b89e9e1bd7915374a55ed62c4fe08fe5ce461f18023eb4ca65fe8ba0783d2949454f40bad8f1f08cef8aa49b81a12b1fe2d42e7d86c6b267aea SHA512 b93041a9f7440aba81501a2beeb3b0f2dfc01aa4e5514c9f03436d005180d07c0e67956301b9afa5e0fe37b55d7fbeaf1f2a1c878accab39400a7622dd4634e0
EBUILD nghttp2-9999.ebuild 1966 BLAKE2B 13541411bb8f29654a24fbfd9bfdcc299ce78dff30bfc05de6d66c433cc12f258d9dcad25d222cc9e9f991322d4ff626a220478f5a7c6c61d6009b920f203938 SHA512 d851b5061afdf03f4724c696489915a820437ae62e927e66c3c4089392f8e01fc62e434718391d255d51f42fe61d420cec3de957b81d3c63103b58ffda3ca4e3
MISC metadata.xml 492 BLAKE2B 76628f4a35c08fe73292c1c50fc6bc90dd44527ee36fb44ff4630a606fe27d9a950afe412fe1565c9eb85355c6fff13400ecb1da5d8c5de8a4765d40b23686f3 SHA512 0e67d6891d7fef473f906db3456a34b4c61f762bf87af6583ce1d477ff090cb69c749669e5cc1a3ef21ee9de3484ea1a094a5971c539edd32a0ab810a4867dcf
diff --git a/net-libs/nghttp2/nghttp2-1.39.2.ebuild b/net-libs/nghttp2/nghttp2-1.39.2.ebuild
new file mode 100644
index 000000000000..1eb2bf7b3f92
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.39.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=7
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha amd64 ~arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+SSL_DEPEND="
+ !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ cxx? (
+ ${SSL_DEPEND}
+ dev-libs/boost:=[${MULTILIB_USEDEP},threads]
+ )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ ${SSL_DEPEND}
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-examples
+ --disable-failmalloc
+ --disable-python-bindings
+ --disable-werror
+ --without-cython
+ $(use_enable cxx asio-lib)
+ $(use_enable debug)
+ $(multilib_native_use_enable hpack-tools)
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ $(multilib_native_use_enable utils app)
+ $(multilib_native_use_with jemalloc)
+ $(multilib_native_use_with xml libxml2)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ if ! use static-libs ; then
+ find "${ED}"/usr -name '*.la' -delete || die
+ fi
+}