summaryrefslogtreecommitdiff
path: root/net-libs/nghttp3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-17 05:37:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-17 05:37:24 +0000
commitc4a46526c2232ba00b0ccc97f2d2a30b0c6baea5 (patch)
tree704e1ac4fe255581fb2a4fdff0d69c5329e1e403 /net-libs/nghttp3
parentd228f661892a9e55a86f00c2c14625490631d797 (diff)
gentoo auto-resync : 17:02:2024 - 05:37:23
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/Manifest2
-rw-r--r--net-libs/nghttp3/nghttp3-1.2.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index 85832e310971..6e59494475e2 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1,4 +1,6 @@
DIST nghttp3-1.1.0.tar.xz 369832 BLAKE2B d6b5ddf7d5809159f4f4d4f8b1750009d05d686bdfdaa882d242cf729f6cc7a950d6095aa0ab22b18d2d9dd7132d0f493bacc635617b5c74f993052bcbb964ce SHA512 30330a8002a296be4441f88f444436baba5e989b8c07dc95c55b43c85de8c2f995b000e88c6d44dc98449c10d9648dd45f641b8b24c0577c3b93e90faeba78b4
+DIST nghttp3-1.2.0.tar.xz 387592 BLAKE2B b3ad897fda5d616a93f063bafde760eda6f597c90de6c81793abef3ff30de05bb2a06388fa868f95c0871a6592331d17a2d344c63817179ad21c6390bc0e499b SHA512 51ade6b17215eb15c92b18ad7a94b70e0a442d5968aee31ec734e5826d09ca34197e64407a1ac3f7bfb4ed1a0b3c3b58afc4a152542bacdcc4c71140931a7652
EBUILD nghttp3-1.1.0.ebuild 885 BLAKE2B 9e709b6314c028a423eee32ae4503483b02036e12b0eeeb7a505bd86603ae6f02a48fe5b01d61d2ee408d485c23b0015600f4c23a185d9e94822c8243aaa5dcc SHA512 2cede4f0b685686965caf4b56a35b31983adebfd2f019b2a5e715a8a4caab2f3835e49a2b1ae88370534b070d79a803198da483d362a0b679e69b88e111b0d63
+EBUILD nghttp3-1.2.0.ebuild 885 BLAKE2B 8caf477d1d6b50b2bfa15ca1437f165195dd75dcdd87033cf1cc350501f98249c7eb0ff7e40d6d7111e844344a2f6962e0829eb128a9b5152a5b73f6062416f0 SHA512 26c38ab4ecc8aad775b21848096b346f788076adf6ea4fe360efec6f25fc7510379691391277f992d8506507ccb04ca3c55136fb585167e3a9e1dc124058496d
EBUILD nghttp3-9999.ebuild 878 BLAKE2B 49d670331582f6d8c895b3bceab220312346e8988b728c6912f480f141ea14a097d63dba4b7e1decacb42b1b26871d63ce69565003fa9230b339498bbdce0339 SHA512 0e2a1cc0513f808cb8cbf1777fb1d45f1f69972da89bd7b80502ee59c2e03741a6a096d6050567f2c1d2aff8227df05c0163582d1920749fe60c7ba772bb4050
MISC metadata.xml 327 BLAKE2B 57c198cb15bb8a8982d7c93149b595e0fd03fb0b63cde2d49349dc3dcefa7873f310a4c6accf7089320c6a38376aef8bf6d98afe689d743c96636eebc53a2365 SHA512 580f5c33715cac0b138070349342d4d2e62c179e05aa1e66fc801001fa8dbb064d1291f8c38ff3b0e68cb392bc2f339c28afeab1d9a77d786497968fae2505a8
diff --git a/net-libs/nghttp3/nghttp3-1.2.0.ebuild b/net-libs/nghttp3/nghttp3-1.2.0.ebuild
new file mode 100644
index 000000000000..c93630cc9fef
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="static-libs test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}