summaryrefslogtreecommitdiff
path: root/net-libs/openslp/openslp-2.0.0-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/openslp/openslp-2.0.0-r5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/openslp/openslp-2.0.0-r5.ebuild')
-rw-r--r--net-libs/openslp/openslp-2.0.0-r5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/openslp/openslp-2.0.0-r5.ebuild b/net-libs/openslp/openslp-2.0.0-r5.ebuild
new file mode 100644
index 000000000000..f41d437d410e
--- /dev/null
+++ b/net-libs/openslp/openslp-2.0.0-r5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools systemd
+
+DESCRIPTION="An open-source implementation of Service Location Protocol"
+HOMEPAGE="http://www.openslp.org/"
+SRC_URI="mirror://sourceforge/openslp/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="libressl"
+RESTRICT="test"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.0-cflags.patch
+ "${FILESDIR}"/${PN}-2.0.0-CVE-2016-4912.patch
+ "${FILESDIR}"/${PN}-2.0.0-CVE-2012-4428.patch
+ "${FILESDIR}"/${PN}-2.0.0-CVE-2016-7567.patch
+ "${FILESDIR}"/${PN}-2.0.0-namespace.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS FAQ ChangeLog NEWS README* THANKS
+ rm -rfv "${D}"/usr/doc
+ dohtml -r .
+ newinitd "${FILESDIR}"/slpd-init slpd
+ systemd_dounit "${FILESDIR}"/slpd.service
+}