summaryrefslogtreecommitdiff
path: root/net-libs/pacparser/pacparser-1.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-27 08:42:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-27 08:42:41 +0100
commit0fcaac21e786bd7911b1e8f436cd885c5e2f6437 (patch)
treeba392915815492b0ce486fc0e3ad5afb4a849b6f /net-libs/pacparser/pacparser-1.4.2.ebuild
parente30edd47e1804bf3ed1ea7be2eac67f4b8cd9f38 (diff)
gentoo auto-resync : 27:10:2023 - 08:42:41
Diffstat (limited to 'net-libs/pacparser/pacparser-1.4.2.ebuild')
-rw-r--r--net-libs/pacparser/pacparser-1.4.2.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/net-libs/pacparser/pacparser-1.4.2.ebuild b/net-libs/pacparser/pacparser-1.4.2.ebuild
new file mode 100644
index 000000000000..e3cd424765ae
--- /dev/null
+++ b/net-libs/pacparser/pacparser-1.4.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit python-r1 toolchain-funcs
+
+DESCRIPTION="Library to parse proxy auto-config files"
+HOMEPAGE="http://pacparser.manugarg.com/"
+SRC_URI="https://github.com/manugarg/${PN}/archive/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc python"
+
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# spidermonkey-1.7.0 is bundled
+# tested unbundling with spidermonkey-1.8* and 1.7
+# and got many failures: unbundling not worth it.
+
+src_prepare() {
+ default
+
+ sed -e '/CC = gcc/d' \
+ -i src/spidermonkey/js/src/config/Linux_All.mk || die
+
+ export NO_INTERNET=yes
+ export VERSION="${PV}"
+ tc-export CC AR RANLIB
+}
+
+src_compile() {
+ # Upstream parallel compilation bug, do that first to work around
+ emake -C src/spidermonkey
+ emake -C src
+ use python && python_foreach_impl emake -C src pymod
+}
+
+src_install() {
+ emake \
+ LIB_PREFIX="${ED}/usr/$(get_libdir)" \
+ DOC_PREFIX="${ED}/usr/share/doc/${PF}" \
+ BIN_PREFIX="${ED}"/usr/bin \
+ INC_PREFIX="${ED}"/usr/include \
+ MAN_PREFIX="${ED}"/usr/share/man \
+ -C src install
+ dodoc README.md
+
+ if use python; then
+ python_foreach_impl emake DESTDIR="${D}" -C src install-pymod
+ python_foreach_impl python_optimize
+ fi
+
+ if use doc; then
+ docompress -x /usr/share/doc/${PF}/{html,examples}
+ else
+ rm -r "${ED}"/usr/share/doc/${PF}/{html,examples} || die
+ fi
+}