summaryrefslogtreecommitdiff
path: root/net-libs/rpcsvc-proto/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-libs/rpcsvc-proto/files
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-libs/rpcsvc-proto/files')
-rw-r--r--net-libs/rpcsvc-proto/files/rpcsvc-proto-1.4-external-libintl.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-libs/rpcsvc-proto/files/rpcsvc-proto-1.4-external-libintl.patch b/net-libs/rpcsvc-proto/files/rpcsvc-proto-1.4-external-libintl.patch
new file mode 100644
index 000000000000..a5088735bbb1
--- /dev/null
+++ b/net-libs/rpcsvc-proto/files/rpcsvc-proto-1.4-external-libintl.patch
@@ -0,0 +1,47 @@
+From 2527c37f956aa38408e251587556a6c8389af319 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Sun, 29 Dec 2019 23:38:28 +0000
+Subject: [PATCH] configure.ac: autodetect need for external libintl
+
+uclibc-ng and macos standard libraries don't provide libintl
+facilities. As a result build fails as
+(x86_64-gentoo-linux-uclibc example):
+
+```
+...
+gcc -g -O2 -o rpcgen rpc_clntout.o rpc_cout.o rpc_hout.o rpc_main.o rpc_parse.o rpc_sample.o rpc_scan.o rpc_svcout.o rpc_tblout.o rpc_util.o
+/usr/lib/gcc/x86_64-gentoo-linux-uclibc/9.2.0/../../../../x86_64-gentoo-linux-uclibc/bin/ld: rpc_main.o: in function `usage':
+/root/rpcsvc-proto/rpcgen/rpc_main.c:1403: undefined reference to `libintl_gettext'
+/usr/lib/gcc/x86_64-gentoo-linux-uclibc/9.2.0/../../../../x86_64-gentoo-linux-uclibc/bin/ld: /root/rpcsvc-proto/rpcgen/rpc_main.c:1404: undefined reference to `libintl_gettext'
+...
+```
+
+The change is simple: add gettext m4 macros to detect need
+for libintl and link to an external library if needed.
+
+Tested on x86_64-glibc and x86_64-uclibc-ng.
+
+Reported-by: Anton
+Bug: https://bugs.gentoo.org/637084
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -16,4 +16,7 @@ AC_ISC_POSIX
+ AC_PROG_INSTALL
+ AC_PROG_MAKE_SET
+
++AM_GNU_GETTEXT([external])
++AM_GNU_GETTEXT_VERSION([0.18.1])
++
+ AC_OUTPUT([Makefile rpcgen/Makefile rpcsvc/Makefile])
+--- a/rpcgen/Makefile.am
++++ b/rpcgen/Makefile.am
+@@ -10,3 +10,4 @@ noinst_HEADERS = proto.h rpc_parse.h rpc_scan.h rpc_util.h
+ rpcgen_SOURCES = rpc_clntout.c rpc_cout.c rpc_hout.c rpc_main.c \
+ rpc_parse.c rpc_sample.c rpc_scan.c rpc_svcout.c rpc_tblout.c \
+ rpc_util.c
++rpcgen_LDADD = $(LIBINTL)
+--
+2.24.1
+