summaryrefslogtreecommitdiff
path: root/net-libs/rpcsvc-proto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /net-libs/rpcsvc-proto
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'net-libs/rpcsvc-proto')
-rw-r--r--net-libs/rpcsvc-proto/Manifest2
-rw-r--r--net-libs/rpcsvc-proto/rpcsvc-proto-1.4.3.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/rpcsvc-proto/Manifest b/net-libs/rpcsvc-proto/Manifest
index d6b954028dc7..102449840a44 100644
--- a/net-libs/rpcsvc-proto/Manifest
+++ b/net-libs/rpcsvc-proto/Manifest
@@ -1,4 +1,6 @@
DIST rpcsvc-proto-1.4.2.tar.gz 61788 BLAKE2B e941fa86088d690e3e80a501beb5169a51ff77b60d618f54db9d9fd5fb96c2b2a4277ab8d847dcdb29dadd2f6947d155b15cd8b6af1f1420e023da8637d555c0 SHA512 6769f9439e3f187eebdeef4ee8d54f8a6fee6f410e3137d0c1b26e61b705873932890856faff55b68c39aa702e456b36fe9410b85baf1ef9b20ee97f2158971a
+DIST rpcsvc-proto-1.4.3.tar.gz 62786 BLAKE2B 9f5cd14b2839c9be654bd237d4b8803536127217a684f21146efc94346c7163010bd30fd9a77e2a5ef3cf69655f3c88de99b8497c863968f02081099f174c115 SHA512 44afac7626147b7c4166bdd90556172bd5d7655f5837245985db7af3cc610de00e215c8cccc4ac6b6a0dd6d0a65d062dc19dab4d1cec0ef45818a7ff709df513
EBUILD rpcsvc-proto-0.ebuild 479 BLAKE2B d02a2aa983d5e6d8dd4820ff83620738db7b90232a13779b30c8d1d496a1e470438cef75a7b6c2022bcaa49e78cc78423160d04a2c753e79225c1103d47fd744 SHA512 8ac3092ffbeaf07868ae78ae28a490812cc2c2a8902de71c7701ff89107f97a42d6be5699285af02d8b0767315c2b5ca5951d2d44542065464d5ed951dd70538
EBUILD rpcsvc-proto-1.4.2.ebuild 946 BLAKE2B 88eaf742a443c3bd611c9f66a54aeb428fee3901dbb879682acc5a5993eaaaf92f86de7e95372a704c1a4f24b9980ad0c7074aae789158d10c89b7e59f0c8d1c SHA512 6f7caaacddc31ad2c5010d3a444551407ffd38d6eca595a0afb05ae0f24eb13562212690f936522c7e377709ae92d45170c81377fc55d27d0e232e2df02d4a47
+EBUILD rpcsvc-proto-1.4.3.ebuild 944 BLAKE2B 1dc4996fc9793edce6f02214256780bebb26d212e25ac6c75df55faef2a7ec50efe53893cb13590fdb69f728b18c219efe9d63b598acf3bcf6c32cbd9a59e39a SHA512 af9f9699f2b3b734314b0cfd0797dbfe77619b205633bb8e7b48027b708c377519473f107c4c6e687818e12c72be3529884ceb226a54bb276770e1fd2493ba7b
MISC metadata.xml 380 BLAKE2B fa4dc82ad37eb111b813c74a2f06e2afc3205abf41fc2287490a5542ea82e49096f6c4fba6ca284b318679d1962e4b32cb1e9c0e29027b04b56019ed4ed0d98e SHA512 f8e686cb3c4d25abe584f58ccb47b9265eaea8ae35ed5beabdb40158f35ffcec8263045d113e782a41791840530c8dd53dfab03ec916a38edfd573a5fb94e2af
diff --git a/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.3.ebuild b/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.3.ebuild
new file mode 100644
index 000000000000..0ce9e567204a
--- /dev/null
+++ b/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="rpcsvc protocol definitions from glibc"
+HOMEPAGE="https://github.com/thkukuk/rpcsvc-proto"
+SRC_URI="https://github.com/thkukuk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+ BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="!<sys-libs/glibc-2.26
+ virtual/libintl"
+# sys-devel/gettext is only for libintl detection macros.
+BDEPEND="sys-devel/gettext"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ # Use ${CHOST}-cpp, not 'cpp': bug #718138
+ # Ideally we should use @CPP@ but rpcgen makes it hard to use '${CHOST}-gcc -E'
+ sed -i -s "s/CPP = \"cpp\";/CPP = \"${CHOST}-cpp\";/" rpcgen/rpc_main.c || die
+}
+
+src_install() {
+ default
+
+ # provided by sys-fs/quota[rpc]
+ rm "${ED}"/usr/include/rpcsvc/rquota.{x,h} || die
+}