summaryrefslogtreecommitdiff
path: root/net-libs/sofia-sip/sofia-sip-1.13.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-24 23:32:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-24 23:32:34 +0100
commit83c7eb1835fcfdf7072b953d23ab34f03c7e8ed6 (patch)
treed44aefcc259a6d52e3d3b0c9929f52aedd24d001 /net-libs/sofia-sip/sofia-sip-1.13.9.ebuild
parent7138219e3c9446bf981ff17f5609f42130bec414 (diff)
gentoo auto-resync : 24:09:2022 - 23:32:34
Diffstat (limited to 'net-libs/sofia-sip/sofia-sip-1.13.9.ebuild')
-rw-r--r--net-libs/sofia-sip/sofia-sip-1.13.9.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/sofia-sip/sofia-sip-1.13.9.ebuild b/net-libs/sofia-sip/sofia-sip-1.13.9.ebuild
new file mode 100644
index 000000000000..d974b5a9f4df
--- /dev/null
+++ b/net-libs/sofia-sip/sofia-sip-1.13.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="RFC3261 compliant SIP User-Agent library"
+HOMEPAGE="https://github.com/freeswitch/sofia-sip"
+SRC_URI="https://github.com/freeswitch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+ BSD public-domain" # See COPYRIGHT
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ ssl? (
+ dev-libs/openssl:0=
+ )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with ssl openssl)
+}
+
+src_install() {
+ default
+ dodoc RELEASE
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}