summaryrefslogtreecommitdiff
path: root/net-libs/stem
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-12 14:20:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-12 14:20:03 +0100
commit522b6bf7e1f6133c288b94a77fc5e3d8eef2c179 (patch)
treec6624f4b91276a0312ca31ebfa276732608dddba /net-libs/stem
parent4d0ca679fbcb59301ffc7af98794c411c5061a0b (diff)
gentoo auto-resync : 12:06:2023 - 14:20:02
Diffstat (limited to 'net-libs/stem')
-rw-r--r--net-libs/stem/Manifest2
-rw-r--r--net-libs/stem/stem-1.8.2.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/stem/Manifest b/net-libs/stem/Manifest
index d82dfdcd3295..af5aad06678c 100644
--- a/net-libs/stem/Manifest
+++ b/net-libs/stem/Manifest
@@ -1,5 +1,7 @@
AUX 1.8.0-replace-all-usages-of-inspect.getargspec.patch 1842 BLAKE2B eef46aa34262df0b7c08596c5040f4688508764cf07bfcefb4368c5cc4cbdf62542880a57c1d53e135d3b70ed3da24dc02225d520afb5972d55175c7930088d3 SHA512 d06d668303bb0b23c223c25d0978ed4573560870c9cb054509ca3244213c76257e165c2ea0789955e045f28067e09fc4833bcf4cbd714f3d7dd96d93a8e8e5e1
AUX 1.8.1-Add-an-exclude-test-argument.patch 7797 BLAKE2B eff2398cf44ee619075be6e49c32d82f99715bfe542922eaa28dc8efd665686411c093174fb19aff084b2f4c25a16219006cf6bcf1396351148a3f737b81c9c4 SHA512 ef9f394be7069e13e303512a2ea73dfe628588f09123df7f72b4f32b17d1eb7d17a5801406f4167f630547adcd5bad84688b5a35471930ad02c70653ba87be87
DIST stem-1.8.1.tar.gz 2859634 BLAKE2B f78da079791583a17eb439a4e2459c7e0af454e45300202df1085d1b1ba150ee097cfa1b93df5ad0d7090644fad6e035604382c73b94744076cad490ab52459a SHA512 bad2f4f96e37caa3ee2928bb027318c4941ca3f6c0072c5f6e87fe647d2b68400ad352d9c27fa2a35c00f4f327aa9cc00e2907b21a9cbd26fab46ec21e2a038a
+DIST stem-1.8.2.tar.gz 2859640 BLAKE2B 4539fc42a463cd1c2ebba10bb31a69d529c41cdaee623beebd3219a2c1d59f8f9b8242b537dd4244e666fb765c5af2729caeeb22a7f8cd1ca6c13dd3cf6aac93 SHA512 f054bbc9a61e04fb7e3b7d1534803b938b855c29795471953661f8fd9c0a5196fe1f9ccfd01e5b3256ea42893a7d57fda34fa54932012e345f74bb3303ff98c5
EBUILD stem-1.8.1.ebuild 1482 BLAKE2B 74799c4c26538e682a771e321515cd228e866ab7448e65672bbc3a90675de3be49b34122f11cd10f1c348e467241102b741ad309451676d3c9a53975d61fb486 SHA512 920e1ca2e66d0a70180d7eebbb06ddd56bb69cd37a2154c09c5c056e2f5b595b54acc23f3b45a6859e5e893880573d4d6dd95438fc11b687501082ef83c0a85f
+EBUILD stem-1.8.2.ebuild 1616 BLAKE2B ba9e3f46768c53d061dcb658792a553acc03cf46a3f24e10b49b58c69a37a89f24a078925b079d2d835d3539689a507536a138acc52e72fd79b12cb9a20c30e6 SHA512 903c8cae8cc4694bc64eb139bb852b75eb20cca40f7044b09efcb1e35b406f1271e324cf148f40cf90e7eba39fd3f0a697007efd7387dc7ba57ff483a2beb1fb
MISC metadata.xml 297 BLAKE2B 9da181ceb341f1e4c5bf37cbcc8f40536c237a20095b4ffc0553996a4cd5d24ccb2b85d248f654a36757a4db5154335949f298a09df7e3d63c3cf74f38253788 SHA512 1400ff80faae768418f7c2e246c09e36a1ea0d66b686adf3251b4b7a57930ad39e935912a539ef3b3c9316f686d7c1191658a28188f3eb1b90ed1a07e7751c77
diff --git a/net-libs/stem/stem-1.8.2.ebuild b/net-libs/stem/stem-1.8.2.ebuild
new file mode 100644
index 000000000000..8cfdad4fb4db
--- /dev/null
+++ b/net-libs/stem/stem-1.8.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="net-vpn/tor"
+BDEPEND="test? ( net-vpn/tor )"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{api,change_log,contents,download,faq,index,tutorials}.rst} )
+
+PATCHES=(
+ # https://github.com/torproject/stem/issues/53
+ "${FILESDIR}"/1.8.1-Add-an-exclude-test-argument.patch
+)
+
+python_prepare_all() {
+ # https://github.com/torproject/stem/issues/56
+ sed -i '/MOCK_VERSION/d' run_tests.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local skipped_tests=(
+ --exclude-test test.integ.installation.TestInstallation.test_install
+ --exclude-test test.integ.util.system.TestSystem.test_expand_path
+ --exclude-test test.integ.control.controller.TestController.test_get_listeners
+ --exclude-test test.integ.control.controller.TestController.test_get_ports
+ --exclude-test test.integ.control.controller.TestController.test_getinfo_freshrelaydescs
+ # confused by exception text change for JSON parsing
+ --exclude-test test.unit.descriptor.collector.TestCollector.test_index_malformed_json
+ )
+
+ # We use --unit --integ to avoid the static/style/lint checks.
+ ${EPYTHON} run_tests.py --verbose --unit --integ "${skipped_tests[@]}" || die "Tests failed with ${EPYTHON}"
+}