summaryrefslogtreecommitdiff
path: root/net-libs/telepathy-glib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /net-libs/telepathy-glib
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'net-libs/telepathy-glib')
-rw-r--r--net-libs/telepathy-glib/Manifest3
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.24.1-r1.ebuild64
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.24.1.ebuild2
3 files changed, 67 insertions, 2 deletions
diff --git a/net-libs/telepathy-glib/Manifest b/net-libs/telepathy-glib/Manifest
index 06bf0bbf5fbb..406b3fd1fb2e 100644
--- a/net-libs/telepathy-glib/Manifest
+++ b/net-libs/telepathy-glib/Manifest
@@ -1,3 +1,4 @@
DIST telepathy-glib-0.24.1.tar.gz 3898149 BLAKE2B a4bc704b5b98c9e6df656833eec38b5f69a0b5d2621a6816ffa6c7da64f2c512cb992ffadd2ec2ac89a1b8cf6581c28aedad6b4019b3d16d9165c7d874370eb6 SHA512 2fed94f76a19d6069f671cdd45d2fd8a4b4ad27c4601aff66041ca205456be397c76a86f92cc9bf20fa4eb6d4c15a67ed8196644c143c37e945f382229a63335
-EBUILD telepathy-glib-0.24.1.ebuild 1539 BLAKE2B 086d1bde9c8cb6a35b79ad12762555d1ec2a4f5ae25ffc170bcceb5f0c21529878d28451de73a5d4266bfccefc5f2449681403e59c66dc4f191992021cd57afe SHA512 fd1493bd6ae89af799937a77931f48270a8188112fa2f145c35c887b2dee20d7121d5419cf8aeb2def87065827882b686ec34d6538987ba89f5675dda3f78779
+EBUILD telepathy-glib-0.24.1-r1.ebuild 1502 BLAKE2B 34436cbe92504b4988f1ea7295a1e3970f932f295912e744889611a14e967dd2c4557e1ec46739e58c5ed7e9eabb65551f5d7fcf81412c43f144c59c5b49a68a SHA512 2dfb9d920b92acfc1100177a43114158a39ccb54e391db71ab6fee8bc975b3533745c2778b9517007c941ecc3efd6f115b7eebca8d3bc34926813dfa6c40907d
+EBUILD telepathy-glib-0.24.1.ebuild 1529 BLAKE2B d600e8e085f9708c3837776a09c43ace1558b90eacc07a5594cd2ebc16d7b499dad761e2efd382bceeb6e491fa2c21f7790701ac470476084121b4b036b54be2 SHA512 92f11d3981cc2d8a9744865c5ae4e69ba9f8100d1ee9bb3364a4a498cd44dcc3de6e1c401898861e3fc8e3833ddbf88821ad84ce4055d5e97275cece5b80642e
MISC metadata.xml 253 BLAKE2B a1efbd3751efaa83ee173f557ec1c8a4497a90b60896cf5a7a07da40b4f94a7a299ca0385477e82b2f5e5dbdf9afa482ccbe21f35ef44214e9c451d764b65529 SHA512 8d59f413993268ca783f7407b676900bb2d964754bf705d4175e2bafbe058a52af74f3928e4bd84d292518f8cf13fab7051486ab7cdc61d02fae6e0188d44442
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.24.1-r1.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.24.1-r1.ebuild
new file mode 100644
index 000000000000..758e5eceb488
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.24.1-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+VALA_MIN_API_VERSION="0.18"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 python-any-r1 vala virtualx
+
+DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol"
+HOMEPAGE="https://telepathy.freedesktop.org/"
+SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="debug +introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# Broken for a long time and upstream doesn't care
+# https://bugs.freedesktop.org/show_bug.cgi?id=63212
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/dbus-glib-0.90
+ introspection? ( >=dev-libs/gobject-introspection-1.30 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+# See bug 504744 for reference
+PDEPEND="
+ net-im/telepathy-mission-control
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-installed-tests \
+ $(use_enable debug backtrace) \
+ $(use_enable debug debug-cache) \
+ $(use_enable introspection) \
+ $(use_enable vala vala-bindings)
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ # Needs dbus for tests (auto-launched)
+ virtx emake -j1 check
+}
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.24.1.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.24.1.ebuild
index ef22c6ee2bec..3469dd10c54f 100644
--- a/net-libs/telepathy-glib/telepathy-glib-0.24.1.ebuild
+++ b/net-libs/telepathy-glib/telepathy-glib-0.24.1.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1+"
SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="alpha amd64 arm arm64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
IUSE="debug +introspection +vala"
REQUIRED_USE="