summaryrefslogtreecommitdiff
path: root/net-libs/usrsctp/usrsctp-0.9.3.0_p20201102.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-libs/usrsctp/usrsctp-0.9.3.0_p20201102.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-libs/usrsctp/usrsctp-0.9.3.0_p20201102.ebuild')
-rw-r--r--net-libs/usrsctp/usrsctp-0.9.3.0_p20201102.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/usrsctp/usrsctp-0.9.3.0_p20201102.ebuild b/net-libs/usrsctp/usrsctp-0.9.3.0_p20201102.ebuild
new file mode 100644
index 000000000000..3f61a85db62a
--- /dev/null
+++ b/net-libs/usrsctp/usrsctp-0.9.3.0_p20201102.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A cross-platform userland SCTP stack"
+HOMEPAGE="https://github.com/sctplab/usrsctp"
+USRSCTP_VERSION="a3e76b281ff5e3469e1c216d47533a73b3b03fab"
+SRC_URI="https://github.com/sctplab/usrsctp/archive/${USRSCTP_VERSION}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( LICENSE.md Manual.md README.md )
+
+S="${WORKDIR}/${PN}-${USRSCTP_VERSION}"
+
+src_configure() {
+ local mycmakeargs=(
+ -Dsctp_werror=0
+ -Dsctp_build_programs=0
+ -Dsctp_build_shared_lib=1
+ )
+ cmake_src_configure
+}