summaryrefslogtreecommitdiff
path: root/net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild')
-rw-r--r--net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild b/net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild
new file mode 100644
index 000000000000..147cd25d9633
--- /dev/null
+++ b/net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zeromq/zmqpp.git"
+else
+ SRC_URI="https://github.com/zeromq/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="ZeroMQ 'highlevel' C++ bindings"
+HOMEPAGE="https://github.com/zeromq/zmqpp"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+IUSE="static-libs"
+
+DEPEND="net-libs/zeromq[static-libs?]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-multilib-strict.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DIS_TRAVIS_CI_BUILD=OFF
+ -DZMQPP_BUILD_SHARED=ON
+ -DZMQPP_BUILD_STATIC=$(usex static-libs)
+ )
+
+ cmake_src_configure
+}