summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-03 03:56:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-03 03:56:37 +0000
commit54e9f9704b37e05c561eadb37d89d30ee7dda9ee (patch)
treebb03a8b10fc448608096c5e872d62b366fc2c93c /net-libs
parent1615d14d4de4360b2241ce5cd8a84157cc86cde0 (diff)
gentoo auto-resync : 03:11:2023 - 03:56:37
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/Manifest.gzbin31960 -> 31962 bytes
-rw-r--r--net-libs/nodejs/Manifest1
-rw-r--r--net-libs/nodejs/nodejs-20.8.1-r1.ebuild261
3 files changed, 262 insertions, 0 deletions
diff --git a/net-libs/Manifest.gz b/net-libs/Manifest.gz
index 91ffa73c4871..125b2a7f0217 100644
--- a/net-libs/Manifest.gz
+++ b/net-libs/Manifest.gz
Binary files differ
diff --git a/net-libs/nodejs/Manifest b/net-libs/nodejs/Manifest
index 9a2d1009f4bb..cfe794e1e195 100644
--- a/net-libs/nodejs/Manifest
+++ b/net-libs/nodejs/Manifest
@@ -15,6 +15,7 @@ EBUILD nodejs-18.18.0.ebuild 7478 BLAKE2B 3d4987f96a43604f05f29da8ae79b3f5a97b15
EBUILD nodejs-18.18.2.ebuild 7458 BLAKE2B 01b42a409e58cb86e36e0fcd3a7f8eb3518ba82e30d0c1b6a2345b44f4b169726d8952b02a0bd451a0aba8e378bf98e0a4a6cf51162b1d3fa5b4722f3d5773e7 SHA512 8b71816ed44923ae812e269128b2ed04a3a9c6654395aac4527a3baef7462e1a300b21eceb3e347b3f74f2ac782196619cc2ef944ec79f245d27fa61eb9e4568
EBUILD nodejs-20.6.1.ebuild 7480 BLAKE2B 96c7b64dadfe2283d0053a56cf20f1f4111ce5549cceb515299567a37a34cc2ce72ada47bfa741e5fd618db60abb6b4aef59a1cf51cf041894ec8c94f34310b1 SHA512 376079de71ee636fe699ee047593451c75d0e7fb51665687e66dacf3f8d29803ce81e71fcd65388c892e6858763c0b3e7a65187d1a1644ea70b77ab7d905183a
EBUILD nodejs-20.7.0.ebuild 7485 BLAKE2B 5908b0f1174bdb46eecbc1a10d7205c498bf0ac642c9b4351bd9f806cd17894d8590d319780148a30586565ab7eea03d829cbff6b85e4eff3d683b77e7d7e9b5 SHA512 b00a2c473ba03384cee2152276b187ed42e63a7c86f84437c719d328217f79fd1ed8239c1f7f1d8b5800af1025194f7c708a3fee08ca959af310cfb00229a06b
+EBUILD nodejs-20.8.1-r1.ebuild 7465 BLAKE2B 233eb4c49f06a5ce94ae2cab57b19e7a06ef295173fab71ef251ce933940c30e44f8ac8e55f0412fee99b00b2f2b6a69108c0ecd274ea546656b3bce2c592188 SHA512 8545c8647a944b35ab4507d206692b70d4e839486cd3460047964671cea8076f0523e6a96b942fd3c8122ccc6c2a865afef99a48c7a8b9409bad8648ecb24ba8
EBUILD nodejs-20.8.1.ebuild 7465 BLAKE2B 02618bb72124bbfb8fd3c2b0f24ee9de866e2dc8d9f632f00a174811dc970d5bb987e772844c077d749935a040a8cab1a7b267c62ef28a3371193eebd7658531 SHA512 aadc2d27b2d8440d2be4a86b51c353fcc02b76b916da75d4b267a0f8a15a8c50521ce43a17ea8e28b825f179f70352fa989d2154eb9c0f27b13ef1a733c85201
EBUILD nodejs-99999999.ebuild 7391 BLAKE2B 892d8f21fafdc5602eb04a877102dbc0d563fbf1c4f2e5f5dca8bdb9dc190eace29023aeec91a8796b63088711e93e67887bc216c3034d08b8ebc4b15e8ba2f9 SHA512 b917bbaa35426b520a2e5af5441a71127d40d7a243e00dbba6602efccb2441a47addb6cd34e4f3d6296016aca10e5190b97314cfce06aa69a2bf9f713554cdae
MISC metadata.xml 986 BLAKE2B 67133c97db85eced638323a93514e084da381b7cbebcab2f0f2ce2781cf0da02be705ab5781c18205a8d4e8b679b6f77f3c9e97ea6ef72b36b6a8a854a39617d SHA512 3f749720ea0623fefa703f8b4563ebabfd5e4aeff4f2e8998576860177d3b1a075afaabc2aa0dc5100df59b3cb787d70d44284976bad3409966b68c11ec64d7a
diff --git a/net-libs/nodejs/nodejs-20.8.1-r1.ebuild b/net-libs/nodejs/nodejs-20.8.1-r1.ebuild
new file mode 100644
index 000000000000..ca388b4b5262
--- /dev/null
+++ b/net-libs/nodejs/nodejs-20.8.1-r1.ebuild
@@ -0,0 +1,261 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CONFIG_CHECK="~ADVISE_SYSCALLS"
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit bash-completion-r1 check-reqs flag-o-matic linux-info pax-utils python-any-r1 toolchain-funcs xdg-utils
+
+DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
+HOMEPAGE="https://nodejs.org/"
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nodejs/node"
+ SLOT="0"
+else
+ SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
+ SLOT="0/$(ver_cut 1)"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x64-macos"
+ S="${WORKDIR}/node-v${PV}"
+fi
+
+IUSE="corepack cpu_flags_x86_sse2 debug doc +icu inspector lto +npm pax-kernel +snapshot +ssl +system-icu +system-ssl test"
+REQUIRED_USE="inspector? ( icu ssl )
+ npm? ( ssl )
+ system-icu? ( icu )
+ system-ssl? ( ssl )
+ x86? ( cpu_flags_x86_sse2 )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-arch/brotli-1.0.9:=
+ >=dev-libs/libuv-1.46.0:=
+ >=net-dns/c-ares-1.18.1:=
+ >=net-libs/nghttp2-1.41.0:=
+ sys-libs/zlib
+ corepack? ( !sys-apps/yarn )
+ system-icu? ( >=dev-libs/icu-71:= )
+ system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
+ sys-devel/gcc:*"
+BDEPEND="${PYTHON_DEPS}
+ dev-util/ninja
+ sys-apps/coreutils
+ virtual/pkgconfig
+ test? ( net-misc/curl )
+ pax-kernel? ( sys-apps/elfix )"
+DEPEND="${RDEPEND}"
+
+# These are measured on a loong machine with -ggdb on, and only checked
+# if debugging flags are present in CFLAGS.
+#
+# The final link consumed a little more than 7GiB alone, so 8GiB is the lower
+# limit for memory usage. Disk usage was 19.1GiB for the build directory and
+# 1.2GiB for the installed image, so we leave some room for architectures with
+# fatter binaries and set the disk requirement to 22GiB.
+CHECKREQS_MEMORY="8G"
+CHECKREQS_DISK_BUILD="22G"
+
+PATCHES=(
+ "${FILESDIR}"/"${PN}"-20.3.0-gcc14.patch
+ )
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]]; then
+ if is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ einfo "Checking for sufficient disk space and memory to build ${PN} with debugging CFLAGS"
+ check-reqs_pkg_pretend
+ fi
+ fi
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ tc-export AR CC CXX PKG_CONFIG
+ export V=1
+ export BUILDTYPE=Release
+
+ # fix compilation on Darwin
+ # https://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+
+ # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
+ local LIBDIR=$(get_libdir)
+ sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
+ sed -i -e "s/'lib'/'${LIBDIR}'/" deps/npm/lib/npm.js || die
+
+ # Avoid writing a depfile, not useful
+ sed -i -e "/DEPFLAGS =/d" tools/gyp/pylib/gyp/generator/make.py || die
+
+ sed -i -e "/'-O3'/d" common.gypi node.gypi || die
+
+ # debug builds. change install path, remove optimisations and override buildtype
+ if use debug; then
+ sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
+ BUILDTYPE=Debug
+ fi
+
+ # We need to disable mprotect on two files when it builds Bug 694100.
+ use pax-kernel && PATCHES+=( "${FILESDIR}"/${PN}-20.6.0-paxmarking.patch )
+
+ default
+}
+
+src_configure() {
+ xdg_environment_reset
+
+ # LTO compiler flags are handled by configure.py itself
+ filter-lto
+ # nodejs unconditionally links to libatomic #869992
+ # specifically it requires __atomic_is_lock_free which
+ # is not yet implemented by sys-libs/compiler-rt (see
+ # https://reviews.llvm.org/D85044?id=287068), therefore
+ # we depend on gcc and force using libgcc as the support lib
+ tc-is-clang && append-ldflags "--rtlib=libgcc --unwindlib=libgcc"
+
+ local myconf=(
+ --ninja
+ --shared-brotli
+ --shared-cares
+ --shared-libuv
+ --shared-nghttp2
+ --shared-zlib
+ )
+ use debug && myconf+=( --debug )
+ use lto && myconf+=( --enable-lto )
+ if use system-icu; then
+ myconf+=( --with-intl=system-icu )
+ elif use icu; then
+ myconf+=( --with-intl=full-icu )
+ else
+ myconf+=( --with-intl=none )
+ fi
+ use corepack || myconf+=( --without-corepack )
+ use inspector || myconf+=( --without-inspector )
+ use npm || myconf+=( --without-npm )
+ use snapshot || myconf+=( --without-node-snapshot )
+ if use ssl; then
+ use system-ssl && myconf+=( --shared-openssl --openssl-use-def-ca-store )
+ else
+ myconf+=( --without-ssl )
+ fi
+
+ local myarch=""
+ case "${ARCH}:${ABI}" in
+ *:amd64) myarch="x64";;
+ *:arm) myarch="arm";;
+ *:arm64) myarch="arm64";;
+ loong:lp64*) myarch="loong64";;
+ riscv:lp64*) myarch="riscv64";;
+ *:ppc64) myarch="ppc64";;
+ *:x32) myarch="x32";;
+ *:x86) myarch="ia32";;
+ *) myarch="${ABI}";;
+ esac
+
+ GYP_DEFINES="linux_use_gold_flags=0
+ linux_use_bundled_binutils=0
+ linux_use_bundled_gold=0" \
+ "${EPYTHON}" configure.py \
+ --prefix="${EPREFIX}"/usr \
+ --dest-cpu=${myarch} \
+ "${myconf[@]}" || die
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ local LIBDIR="${ED}/usr/$(get_libdir)"
+ default
+
+ pax-mark -m "${ED}"/usr/bin/node
+
+ # set up a symlink structure that node-gyp expects..
+ dodir /usr/include/node/deps/{v8,uv}
+ dosym . /usr/include/node/src
+ for var in deps/{uv,v8}/include; do
+ dosym ../.. /usr/include/node/${var}
+ done
+
+ if use doc; then
+ docinto html
+ dodoc -r "${S}"/doc/*
+ fi
+
+ if use npm; then
+ keepdir /etc/npm
+ echo "NPM_CONFIG_GLOBALCONFIG=${EPREFIX}/etc/npm/npmrc" > "${T}"/50npm
+ doenvd "${T}"/50npm
+
+ # Install bash completion for `npm`
+ local tmp_npm_completion_file="$(TMPDIR="${T}" mktemp -t npm.XXXXXXXXXX)"
+ "${ED}/usr/bin/npm" completion > "${tmp_npm_completion_file}"
+ newbashcomp "${tmp_npm_completion_file}" npm
+
+ # Move man pages
+ doman "${LIBDIR}"/node_modules/npm/man/man{1,5,7}/*
+
+ # Clean up
+ rm -f "${LIBDIR}"/node_modules/npm/{.mailmap,.npmignore,Makefile}
+ rm -rf "${LIBDIR}"/node_modules/npm/{doc,html,man}
+
+ local find_exp="-or -name"
+ local find_name=()
+ for match in "AUTHORS*" "CHANGELOG*" "CONTRIBUT*" "README*" \
+ ".travis.yml" ".eslint*" ".wercker.yml" ".npmignore" \
+ "*.md" "*.markdown" "*.bat" "*.cmd"; do
+ find_name+=( ${find_exp} "${match}" )
+ done
+
+ # Remove various development and/or inappropriate files and
+ # useless docs of dependend packages.
+ find "${LIBDIR}"/node_modules \
+ \( -type d -name examples \) -or \( -type f \( \
+ -iname "LICEN?E*" \
+ "${find_name[@]}" \
+ \) \) -exec rm -rf "{}" \;
+ fi
+
+ use corepack &&
+ "${D}"/usr/bin/corepack enable --install-directory "${D}"/usr/bin
+
+ mv "${ED}"/usr/share/doc/node "${ED}"/usr/share/doc/${PF} || die
+}
+
+src_test() {
+ local drop_tests=(
+ test/parallel/test-fs-read-stream.js
+ test/parallel/test-dns-setserver-when-querying.js
+ test/parallel/test-fs-mkdir.js
+ test/parallel/test-fs-utimes-y2K38.js
+ test/parallel/test-fs-watch-recursive-add-file.js
+ test/parallel/test-release-npm.js
+ test/parallel/test-socket-write-after-fin-error.js
+ test/parallel/test-strace-openat-openssl.js
+ test/sequential/test-util-debug.js
+ )
+ rm -f "${drop_tests[@]}" || die "disabling tests failed"
+
+ out/${BUILDTYPE}/cctest || die
+ "${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} --flaky-tests=dontcare -J message parallel sequential || die
+}
+
+pkg_postinst() {
+ if use npm; then
+ ewarn "remember to run: source /etc/profile if you plan to use nodejs"
+ ewarn " in your current shell"
+ fi
+}