summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-19 20:39:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-19 20:39:44 +0100
commit54eca75a4e3e380e1d386f4d235baeb7d4ff332e (patch)
tree5f59a3e7b9069e5ab5ae4c5b46184560dc318692 /net-libs
parentfc7e841956ae3cc385629bf33433de23a6d04db6 (diff)
gentoo auto-resync : 19:07:2022 - 20:39:44
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/Manifest.gzbin32448 -> 32454 bytes
-rw-r--r--net-libs/nodejs/Manifest1
-rw-r--r--net-libs/nodejs/files/nodejs-12.22.1-jinja_collections_abc.patch95
-rw-r--r--net-libs/tox/Manifest2
-rw-r--r--net-libs/tox/tox-0.2.18-r1.ebuild (renamed from net-libs/tox/tox-0.2.18.ebuild)6
5 files changed, 4 insertions, 100 deletions
diff --git a/net-libs/Manifest.gz b/net-libs/Manifest.gz
index 6abc13e1c5c2..a8500bcb9e4d 100644
--- a/net-libs/Manifest.gz
+++ b/net-libs/Manifest.gz
Binary files differ
diff --git a/net-libs/nodejs/Manifest b/net-libs/nodejs/Manifest
index 37aa9d3e7416..cefe392f5ac7 100644
--- a/net-libs/nodejs/Manifest
+++ b/net-libs/nodejs/Manifest
@@ -1,4 +1,3 @@
-AUX nodejs-12.22.1-jinja_collections_abc.patch 3159 BLAKE2B 52de2f76151fffa436bf8a53ef6f38cee0cc566832a31c68cfb8fd36a82a187cebe389041355137b2f2a53454e26b0460bfc8a63154528d51264aa01503db10f SHA512 197ae5b316af6a253614fb0f9cdef644678a9eede770b3443ab417397c40caea1fc00c7300dd67af859ffeab56a851b70778bc68bc915559fab1f3dcb27c0461
AUX nodejs-12.22.5-shared_c-ares_nameser_h.patch 15742 BLAKE2B e55d3aec80abffc81230ea46619d82d61fd2266ef62a96f39c47d7f9f5b6f61a4e978475c2e963214abdc45d5582d98c21e6be9f926f078108feb5f655b5c88a SHA512 080ede859262f5507a913b1f9995092ed075777e94c73c23ee74d74c739e9b2e6b4cc3afad189a333692f10485e7e3e12a15662286df2c946f73bdd6083baee8
AUX nodejs-13.8.0-paxmarking.patch 4209 BLAKE2B 35a100bc24b638beb35e021a79c1687f8ddefdadbcf08e41d2f860451f7ec6fe8011afdf0198e8f973df7a0fcedd2f66bd3bcf7389be06c27e265822103fc79e SHA512 10d6206e80e7583ba5cd0977d6e067935dc51c00e3c16246dd4f34720a025d1a7b1a794ab7cd0e6a14d4b6d07438735da8230e2fb849f31e05a3372628d42f23
AUX nodejs-14.15.0-fix_ppc64_crashes.patch 1633 BLAKE2B cded0eba081ff80f02ebc019d976503cc30ed8fd9974951d9c8b9dd659db7f17e54f30d59ec171711cfeeda16d43ed49d8b0fc1574c07014d5266c578de02814 SHA512 14b9b0a5963deafb972f455867831ecb349ffd5af229467c1e985c9a6c4f0f4f0faf905a51e50b8a6bf130040dde45407b37ab6d7ad6b1ecb9ef8209d9585396
diff --git a/net-libs/nodejs/files/nodejs-12.22.1-jinja_collections_abc.patch b/net-libs/nodejs/files/nodejs-12.22.1-jinja_collections_abc.patch
deleted file mode 100644
index 5f0df09b6e2e..000000000000
--- a/net-libs/nodejs/files/nodejs-12.22.1-jinja_collections_abc.patch
+++ /dev/null
@@ -1,95 +0,0 @@
---- a/deps/v8/third_party/jinja2/tests.py
-+++ b/deps/v8/third_party/jinja2/tests.py
-@@ -10,7 +10,7 @@
- """
- import operator
- import re
--from collections import Mapping
-+from collections.abc import Mapping
- from jinja2.runtime import Undefined
- from jinja2._compat import text_type, string_types, integer_types
- import decimal
---- a/deps/v8/third_party/jinja2/runtime.py
-+++ b/deps/v8/third_party/jinja2/runtime.py
-@@ -315,7 +315,7 @@ class Context(with_metaclass(ContextMeta)):
-
- # register the context as mapping if possible
- try:
-- from collections import Mapping
-+ from collections.abc import Mapping
- Mapping.register(Context)
- except ImportError:
- pass
---- a/deps/v8/third_party/jinja2/sandbox.py
-+++ b/deps/v8/third_party/jinja2/sandbox.py
-@@ -14,7 +14,7 @@
- """
- import types
- import operator
--from collections import Mapping
-+from collections.abc import Mapping
- from jinja2.environment import Environment
- from jinja2.exceptions import SecurityError
- from jinja2._compat import string_types, PY2
-@@ -79,7 +79,7 @@ except ImportError:
- pass
-
- #: register Python 2.6 abstract base classes
--from collections import MutableSet, MutableMapping, MutableSequence
-+from collections.abc import MutableSet, MutableMapping, MutableSequence
- _mutable_set_types += (MutableSet,)
- _mutable_mapping_types += (MutableMapping,)
- _mutable_sequence_types += (MutableSequence,)
---- a/deps/v8/third_party/jinja2/utils.py
-+++ b/deps/v8/third_party/jinja2/utils.py
-@@ -482,7 +482,7 @@ class LRUCache(object):
-
- # register the LRU cache as mutable mapping if possible
- try:
-- from collections import MutableMapping
-+ from collections.abc import MutableMapping
- MutableMapping.register(LRUCache)
- except ImportError:
- pass
---- a/tools/inspector_protocol/jinja2/runtime.py
-+++ b/tools/inspector_protocol/jinja2/runtime.py
-@@ -315,7 +315,7 @@ class Context(with_metaclass(ContextMeta)):
-
- # register the context as mapping if possible
- try:
-- from collections import Mapping
-+ from collections.abc import Mapping
- Mapping.register(Context)
- except ImportError:
- pass
---- a/tools/inspector_protocol/jinja2/sandbox.py
-+++ b/tools/inspector_protocol/jinja2/sandbox.py
-@@ -14,7 +14,7 @@
- """
- import types
- import operator
--from collections import Mapping
-+from collections.abc import Mapping
- from jinja2.environment import Environment
- from jinja2.exceptions import SecurityError
- from jinja2._compat import string_types, PY2
-@@ -79,7 +79,7 @@ except ImportError:
- pass
-
- #: register Python 2.6 abstract base classes
--from collections import MutableSet, MutableMapping, MutableSequence
-+from collections.abc import MutableSet, MutableMapping, MutableSequence
- _mutable_set_types += (MutableSet,)
- _mutable_mapping_types += (MutableMapping,)
- _mutable_sequence_types += (MutableSequence,)
---- a/tools/inspector_protocol/jinja2/tests.py
-+++ b/tools/inspector_protocol/jinja2/tests.py
-@@ -10,7 +10,7 @@
- """
- import operator
- import re
--from collections import Mapping
-+from collections.abc import Mapping
- from jinja2.runtime import Undefined
- from jinja2._compat import text_type, string_types, integer_types
- import decimal
diff --git a/net-libs/tox/Manifest b/net-libs/tox/Manifest
index fd38d887de03..4a2b326b986b 100644
--- a/net-libs/tox/Manifest
+++ b/net-libs/tox/Manifest
@@ -5,6 +5,6 @@ AUX tox-bootstrapd.service 365 BLAKE2B f17891d280007180811414f85f1f8a4defd854364
DIST c-toxcore-0.2.13.tar.gz 511533 BLAKE2B 8c68180710e3d06eaaef9fc05dc0ff2492907586934d1d6f57f147e07bb78b262f78b0057911e4b5cd27d2d1efb51cb714f757b90caa269988e604cafa62cd00 SHA512 f4ed9ea4afb7f9c14a5afd949f3a52e7880838c910acaf5adc39acb09ad574406be08f43b76a9fbdd4fc4bd14f0d73212dc7bd10783565055c910c6c3e5e357a
DIST c-toxcore-0.2.18.tar.gz 653247 BLAKE2B c27da02753aede5056c42e5bf1949920fc30e98a23c058ab445c2fe345271e442885a3eeb011e8fde16d8fc8451376a015c5f821145785c75e7d0dda3a8b72eb SHA512 e9b0d73a2e0460290c8453a0a64fc91deed2e0cf87f945d0ba203b929f19a296571d7140f4df89b06f7e67f2b61894460ce4dd32ab9ecf6ea7d5b67538fadb23
EBUILD tox-0.2.13.ebuild 2920 BLAKE2B 59bf6f61244b267d49a181359b3322186efe21217578b6561b41dcd798e50bc9104beb27dbd611485949a112a80ab11d774f4f17a18cdfb23f4ef106729383cc SHA512 8fdb59395d4ce07c6f2edbfc8a8672b021a0b32d62682ecc697e9e816be09d31587be9c41e9b5755aaab1570d9c7aa12d84e3ac6c7b68abdc0c1a099df35fb75
-EBUILD tox-0.2.18.ebuild 3232 BLAKE2B 7d80c32b5c5a0240d7643f46ee29ab87a04aa6a08f798ce5d6c6a9a62ae9261b383412aac8938710562a180a522f2785aa455699b5cf14bdcf48b8ef319d98e9 SHA512 ed7899eafb63ecde109c8294f74668c31dbd92602c8f4f803b3bd4d8953f743028b01d168aaaf4052f99b9060607d856828ab63a93ee8f53fab15c3e3359533b
+EBUILD tox-0.2.18-r1.ebuild 3234 BLAKE2B 43fef21afc144c156f67891b6fe0e5d4fc5b07bd0784ce22125f7876e0b369fe104b21cc7605f23385bf3852e2ff2973727653759601de4c275f10f530f118c5 SHA512 59f1d8f6f37967123e1b429e318ba2432ded6b0ff61db9bc2515a07c76ac7cdfc5aa026b9e43c9afb53012a0097b681a8d699190f9f8e7e29ac1e1177085092e
EBUILD tox-9999.ebuild 3088 BLAKE2B 689337dbd95cf6b20186473cc642947763c4f8577c305df4aad55b6e74e6feb1cee7898a7d8651ea7e57491d85b3ff136c914c2c76bbce64db6059ecea3d7525 SHA512 8ed472219c205c7524ce1fca59948abe261de025713e5b2f1d90681f1411cc3c94bba5b096e1b164d59ae1a7b8eca9349b45d81189edbdc1c80240ab54691886
MISC metadata.xml 985 BLAKE2B a77c49ccdcb1407dc40590f2fbcd4a932d1167dbaad973c878da09107def195cc9755c6d5f1a824cf22006543f1f6db3461d03e11ba7a21b3f321b6173c8aee8 SHA512 67eecd0db74c985cd97c840414ff6860a1d5a3ac9eaa00cd73c5c61e59831ff458a596251605af9515817f074d76eb342c12714409e7b31176d56e9ee311fc0c
diff --git a/net-libs/tox/tox-0.2.18.ebuild b/net-libs/tox/tox-0.2.18-r1.ebuild
index 4296b1ad05d7..00753d1f6819 100644
--- a/net-libs/tox/tox-0.2.18.ebuild
+++ b/net-libs/tox/tox-0.2.18-r1.ebuild
@@ -5,7 +5,9 @@ EAPI=8
inherit cmake systemd
-MY_P=c-toxcore-${PV}
+MY_P="c-toxcore-${PV}"
+S="${WORKDIR}/${MY_P}"
+
DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
HOMEPAGE="https://tox.chat https://github.com/TokTok/c-toxcore"
SRC_URI="https://github.com/TokTok/c-toxcore/releases/download/v${PV}/${MY_P}.tar.gz"
@@ -35,8 +37,6 @@ RDEPEND="${DEPEND}
)
key-utils? ( || ( sys-devel/gcc[openmp] sys-devel/clang-runtime[openmp] ) )"
-S="${WORKDIR}"/${MY_P}
-
src_prepare() {
cmake_src_prepare