summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-25 08:55:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-25 08:55:56 +0100
commitbf2c6ad6782df5963101bc3e73c0d31d65e0829f (patch)
tree576f80a009b285b5cfedf66ecadc7182810684e7 /net-libs
parentaeb34c47a1042b074096bacb85205617c8a14d3a (diff)
gentoo auto-resync : 25:07:2022 - 08:55:56
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/Manifest.gzbin32456 -> 32463 bytes
-rw-r--r--net-libs/libtorrent-rasterbar/Manifest2
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.7.ebuild74
3 files changed, 76 insertions, 0 deletions
diff --git a/net-libs/Manifest.gz b/net-libs/Manifest.gz
index 249932ab16ff..cde6f8924ea5 100644
--- a/net-libs/Manifest.gz
+++ b/net-libs/Manifest.gz
Binary files differ
diff --git a/net-libs/libtorrent-rasterbar/Manifest b/net-libs/libtorrent-rasterbar/Manifest
index 0d5f81094562..da73c62df1b5 100644
--- a/net-libs/libtorrent-rasterbar/Manifest
+++ b/net-libs/libtorrent-rasterbar/Manifest
@@ -1,3 +1,5 @@
DIST libtorrent-rasterbar-2.0.6.tar.gz 4431174 BLAKE2B 4951a102b68a5a7ba9a98d771ca638e8438b2aeaa95f5d7bf616542c7a02d28e184ee1bf5b7a55cd91a068cd2d4e9756c479e4ddb5eabe89d8aa833d70aa7502 SHA512 4a5d710706040ef6193967dbb13998cb0ddebe7e95c3bf8aec0812876027c68c32b001fd3f07cd4ff1b819660a8d46ae8c7077e72caf92572288a51cdec7daea
+DIST libtorrent-rasterbar-2.0.7.tar.gz 4453469 BLAKE2B b04884c55cb96031f6bfcef786ea101d18bb9310ec2e1ed528e27d8f625712855726575beae127f24c007144bb85e1eba293da748ad06794c58ebd9b38ec5aac SHA512 30e558245a261ccf3f23815a037477ae6da1a02da0b7b3aa40383058c5782a341a11ae684f959efc1c9b39e31475ec31451b9ff4b2db3c0bfccc4d42bd6d69c1
EBUILD libtorrent-rasterbar-2.0.6.ebuild 1850 BLAKE2B 2b4fe24bef99ac335a888f653d4d2402e0cfeb919704931186354bb37fd29898b795672759e2811fc9035d7973d59b6fd9fce722aabe2f64bf458c7a1b799bb7 SHA512 28ce23d78b2f0bf91b4be1c21433971e47c1805feec0b9f0dd28eab906d30ee00495e1fa601e14fc291b89874bf16ab0afa29d57ea4e924b178720f264174e9f
+EBUILD libtorrent-rasterbar-2.0.7.ebuild 1851 BLAKE2B 3cefb7b25d67e46f6e1d1c2c6000c2fa2b321a029e5d5c7b74461cc2f7bdf457c256f36289d3a0ee24fa0d84e664079dd9b271c762726fb19cbb21537f088443 SHA512 dba82575180c909b129cd783537d0d874fc98f70524050492db397449672928382d4af804da71b4b0b690338ce051f615d5e77d79f12299fa6bd806eee17942f
MISC metadata.xml 638 BLAKE2B e4ea9381097b54924059f7682aead071561015a3842a6089927840ce24fdac16101cce2c57e01431800c1e471c34117038d10a8b82d70aaed555573a9d4d03d6 SHA512 49f5bd5348f054bec0a2646f96803ab6d2dcf6a0b0f32c9ccfb05a7055012a40703b1e9ddf912827c9197ab1a740fd41b98cd7e993f5f30633686e5b102bdec2
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.7.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.7.ebuild
new file mode 100644
index 000000000000..1e94d55e8111
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.7.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="https://libtorrent.org/ https://github.com/arvidn/libtorrent"
+SRC_URI="https://github.com/arvidn/libtorrent/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+dht debug gnutls python ssl test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/boost:=[threads(+)]
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost[python,${PYTHON_USEDEP}]
+ ')
+ )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="python? (
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')
+ )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_CXX_STANDARD=17
+ -DBUILD_SHARED_LIBS=ON
+ -Dbuild_examples=OFF
+ -Ddht=$(usex dht ON OFF)
+ -Dencryption=$(usex ssl ON OFF)
+ -Dgnutls=$(usex gnutls ON OFF)
+ -Dlogging=$(usex debug ON OFF)
+ -Dpython-bindings=$(usex python ON OFF)
+ -Dbuild_tests=$(usex test ON OFF)
+ )
+
+ # We need to drop the . from the Python version to satisfy Boost's
+ # FindBoost.cmake module, bug #793038.
+ use python && mycmakeargs+=( -Dboost-python-module-name="${EPYTHON/./}" )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # Needs running UPnP server
+ -E "test_upnp"
+ )
+
+ # Checked out Fedora's test workarounds for inspiration
+ # https://src.fedoraproject.org/rpms/rb_libtorrent/blob/rawhide/f/rb_libtorrent.spec#_120
+ LD_LIBRARY_PATH="${BUILD_DIR}:${LD_LIBRARY_PATH}" cmake_src_test
+}