summaryrefslogtreecommitdiff
path: root/net-mail/altermime/altermime-0.3.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/altermime/altermime-0.3.11.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/altermime/altermime-0.3.11.ebuild')
-rw-r--r--net-mail/altermime/altermime-0.3.11.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-mail/altermime/altermime-0.3.11.ebuild b/net-mail/altermime/altermime-0.3.11.ebuild
new file mode 100644
index 000000000000..9d8ff8c549ae
--- /dev/null
+++ b/net-mail/altermime/altermime-0.3.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION=" alterMIME is a small program which is used to alter your mime-encoded mailpacks"
+SRC_URI="http://www.pldaniels.com/altermime/${P}.tar.gz"
+HOMEPAGE="http://pldaniels.com/altermime/"
+
+LICENSE="Sendmail"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.3.10-MIME_headers-overflow.patch \
+ "${FILESDIR}"/${P}-respect-flags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ dobin altermime
+ dodoc CHANGELOG README
+}