summaryrefslogtreecommitdiff
path: root/net-mail/altermime/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/altermime/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/altermime/files')
-rw-r--r--net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch13
-rw-r--r--net-mail/altermime/files/altermime-0.3.11-respect-flags.patch20
2 files changed, 33 insertions, 0 deletions
diff --git a/net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch b/net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch
new file mode 100644
index 000000000000..bca39afba7f2
--- /dev/null
+++ b/net-mail/altermime/files/altermime-0.3.10-MIME_headers-overflow.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/320785
+
+--- MIME_headers.c
++++ MIME_headers.c
+@@ -2243,7 +2243,7 @@
+ {
+ if (MIMEH_DNORMAL) LOGGER_log("%s:%d:MIME_parse_contentlocation:DEBUG: filename = %s\n", FL, p);
+ snprintf(hinfo->name, sizeof(hinfo->name),"%s",p);
+- snprintf(hinfo->filename, sizeof(hinfo->name),"%s",p);
++ snprintf(hinfo->filename, sizeof(hinfo->filename),"%s",p);
+ FNFILTER_filter(hinfo->filename, _MIMEH_FILENAMELEN_MAX);
+ SS_push(&(hinfo->ss_filenames), hinfo->filename, strlen(hinfo->filename));
+
diff --git a/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch b/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch
new file mode 100644
index 000000000000..9f114ca17491
--- /dev/null
+++ b/net-mail/altermime/files/altermime-0.3.11-respect-flags.patch
@@ -0,0 +1,20 @@
+--- altermime-0.3.11.orig/Makefile
++++ altermime-0.3.11/Makefile
+@@ -9,7 +9,7 @@
+ # opposite of a disclaimer.
+ ALTERMIME_OPTIONS=-DALTERMIME_PRETEXT
+ #ALTERMIME_OPTIONS=
+-CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
++CFLAGS+=-Wall $(ALTERMIME_OPTIONS)
+ OBJS= strstack.o mime_alter.o ffget.o pldstr.o filename-filters.o logger.o MIME_headers.o libmime-decoders.o boundary-stack.o qpe.o
+
+
+@@ -19,7 +19,7 @@
+ all: altermime
+
+ altermime: altermime.c ${OBJS}
+- ${CC} ${CFLAGS} altermime.c ${OBJS} -o altermime
++ ${CC} ${CFLAGS} ${LDFLAGS} altermime.c ${OBJS} -o altermime
+
+
+ # Build Install