summaryrefslogtreecommitdiff
path: root/net-mail/automx2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
commita3bb28551df94028000fb72308a9e9baa01458b0 (patch)
tree33b14c7bf0dffbd5bb04dbd5b395514ebdda4896 /net-mail/automx2
parent6657c680376cedf378fcf328e5fa03ed3b41d580 (diff)
gentoo auto-resync : 03:06:2024 - 00:07:25
Diffstat (limited to 'net-mail/automx2')
-rw-r--r--net-mail/automx2/Manifest3
-rw-r--r--net-mail/automx2/automx2-2022.1-r1.ebuild46
-rw-r--r--net-mail/automx2/metadata.xml2
3 files changed, 49 insertions, 2 deletions
diff --git a/net-mail/automx2/Manifest b/net-mail/automx2/Manifest
index f86fed299346..79aa69e145a7 100644
--- a/net-mail/automx2/Manifest
+++ b/net-mail/automx2/Manifest
@@ -2,5 +2,6 @@ AUX conf 721 BLAKE2B 976a2936da5e9eef71d9d08f7f12c51151549c23c27918de28da355e87e
AUX confd 213 BLAKE2B 2573f19bdc9022357f2f92ff17d84a1e77078c6c05a46a09b6e57ab7132d1f1078fb5003640f83213f746f94e3ab5b482b01d92feb94684665eb4e796a642841 SHA512 6c04de3ef26fd132269532c7bdca3263e95cebf5078ddd57e8ebff62229fabfb64b8ad4d988dfe99c9611c5d1081b4d3862f09d11c08aa1aabc1d5bc7c987439
AUX init-r1 608 BLAKE2B 7d2b93482c62fe0219c7194279ee495274e4b0b8319ccf2d24e7816abe7eb23452bc21c01305283deeb8224c3668641b1bd5a7f3fbf8fe783a28e58268511ace SHA512 4a1ed2c45e1414734b8e5cbb731377da2087bd4f1a1075b4acb81b5057a65c0557e9e1a05cdf6856da35067a589d9c56fcf13156e8872facfc8f161bb3cade0f
DIST automx2-2022.1.tar.gz 182519 BLAKE2B baf2ecc801f6f024eb6a6fe2610d6cb7c3dd0726cfa877fdea76d94ebf16b9393addc5be8844f3017fd664b73adc74f2cd898736bbcad1fa0b2b3c1022cb638a SHA512 3d6fb9cf01cff641c78851560d72e3d80f9011cca4cd438cd49e999feef3f290bbd9495655f41319eb5456beac09bb8862dc327b521254266e0d53aa17b0bbd3
+EBUILD automx2-2022.1-r1.ebuild 1141 BLAKE2B 4b32b662798301253ac5fb2ace1607072ce54d4aa8efb81ecfb8b3b04bc40809c0a35ee9659407c2372cdd1d657bd96f93ebe1ce2114614e67c522f5e2619c7f SHA512 523417fccc10f0bb768a1f02a98c380885cba7b5bd1c257716378e019520fde36d44964602826d233b582e1ce218290be6e85ccb400acfa27143da87e46e166f
EBUILD automx2-2022.1.ebuild 1123 BLAKE2B 94b1f59b450dd22148a2e6f8cdf397583fb13bfb1ae10de2a7c7adf08c56cdcc74920167c6ddcccd5bfbfc1e470bb43e697a6c62f5530136b192e47cc48c36ba SHA512 6ed7e6e6c28afc3f58310b3a4e3aae99fe509deb74641cca09c6f4de7848879ec1016d7dfbbc8d250a75602a12a4ed764f13e6748dbc3554f5f39e9d3375b988
-MISC metadata.xml 690 BLAKE2B 93cac84cef0aafc4d7b5a12f420b65454c02071ee7ec3c1d15b6429fcc841bcccc94e6652da3a8f82ab7feeb3e875cdf3566de5561e10de6bdf09472aa61c80f SHA512 e332e3e64a8bb7898b79a972cbd8d8758933e33986e96df2619f65ce9e49022e8c756a1b248c21738ef7942df5154a1ce54b934021c10661a295749dfed129cd
+MISC metadata.xml 662 BLAKE2B 0751c66d39b941b5fe181be51254b0d22192af56bdf016ac72e5b4f8ab0fe579424ee587d23e66d29a5f87726ac0e1fa47c9b0b71de5d9d1bed7b834b16d5bee SHA512 b50f93ec5909b8f12992b79bdf173199bf0aab37df9420111cc487ccd9e3aab92e78aa4742fbb90043648b95e1c29d3aece003fd39f20314ebc7d11c70b1dd0a
diff --git a/net-mail/automx2/automx2-2022.1-r1.ebuild b/net-mail/automx2/automx2-2022.1-r1.ebuild
new file mode 100644
index 000000000000..05f26b65305a
--- /dev/null
+++ b/net-mail/automx2/automx2-2022.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11,12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Email client autoconfiguration service"
+HOMEPAGE="https://rseichter.github.io/automx2/"
+SRC_URI="https://github.com/rseichter/automx2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="acct-user/automx2
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-migrate[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/ldap3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -i -e "/('scripts'/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x AUTOMX2_CONF="tests/unittest.conf"
+ eunittest tests/
+}
+
+python_install_all() {
+ local DOCS=( "${S}"/docs/*.adoc "${S}"/contrib/*sample.conf )
+ local HTML_DOCS=( "${S}"/docs/*.{html,svg} )
+ newconfd "${FILESDIR}/confd" "${PN}"
+ newinitd "${FILESDIR}/init-r1" "${PN}"
+ insinto /etc
+ newins "${FILESDIR}/conf" "${PN}.conf"
+ distutils-r1_python_install_all
+}
diff --git a/net-mail/automx2/metadata.xml b/net-mail/automx2/metadata.xml
index 54630a522f9b..01690ef05208 100644
--- a/net-mail/automx2/metadata.xml
+++ b/net-mail/automx2/metadata.xml
@@ -10,7 +10,7 @@
(autoconfig) in one tool.
</longdescription>
<upstream>
- <doc>https://github.com/rseichter/automx2/blob/master/doc/automx2.pdf</doc>
+ <doc>https://rseichter.github.io/automx2/</doc>
<maintainer>
<email>automx2@seichter.de</email>
<name>Ralph Seichter</name>