summaryrefslogtreecommitdiff
path: root/net-mail/cyrus-imapd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/cyrus-imapd/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/cyrus-imapd/files')
-rw-r--r--net-mail/cyrus-imapd/files/cyrus-imapd-db.patch81
-rw-r--r--net-mail/cyrus-imapd/files/cyrus-imapd-fix-tests.patch21
-rw-r--r--net-mail/cyrus-imapd/files/cyrus-imapd-libcap-libs.patch35
-rw-r--r--net-mail/cyrus-imapd/files/cyrus-imapd-sieve-libs-v4.patch127
-rw-r--r--net-mail/cyrus-imapd/files/cyrus-imapd-sieve-libs.patch43
-rw-r--r--net-mail/cyrus-imapd/files/cyrus.conf41
-rw-r--r--net-mail/cyrus-imapd/files/cyrus.confd5
-rw-r--r--net-mail/cyrus-imapd/files/cyrus.pam-include6
-rw-r--r--net-mail/cyrus-imapd/files/cyrus.rc622
-rw-r--r--net-mail/cyrus-imapd/files/cyrus.rc722
-rw-r--r--net-mail/cyrus-imapd/files/cyrus.rc834
-rw-r--r--net-mail/cyrus-imapd/files/imapd.conf50
12 files changed, 487 insertions, 0 deletions
diff --git a/net-mail/cyrus-imapd/files/cyrus-imapd-db.patch b/net-mail/cyrus-imapd/files/cyrus-imapd-db.patch
new file mode 100644
index 000000000000..f720cf2cb127
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus-imapd-db.patch
@@ -0,0 +1,81 @@
+--- configure.ac 2015-07-06 01:22:19.000000000 +0000
++++ configure.ac 2015-07-22 11:18:33.000000000 +0000
+@@ -236,50 +236,29 @@
+ dnl Berkeley DB Detection
+
+ AC_ARG_WITH(bdb,
+- [AS_HELP_STRING([--with-bdb=DIR], [use Berkeley DB (in DIR) [yes]])],
+- with_bdb=$withval, with_bdb="yes")
+-
+-dnl support old-style
+-AC_ARG_WITH(dbdir,, with_bdb=$withval)
++ [AS_HELP_STRING([--with-bdb], [use Berkeley DB [yes]])],
++ [],
++ [with_bdb="yes"])
+
++# On a properly installed system, we build
++# by including <db.h> and by linking with -ldb
+ case "$with_bdb" in
+- no)
+- use_berkeley="no"
+- ;;
+- yes)
+- use_berkeley="yes"
+- with_bdb_lib=none
+- with_bdb_inc=none
+- ;;
+- *)
+- use_berkeley="yes"
+- with_bdb_lib="$with_bdb/lib"
+- with_bdb_inc="$with_bdb/include"
++ no) ;;
++ *) AC_CHECK_FILE([/usr/include/db.h],
++ [],
++ AC_CHECK_FILE([/usr/include/db/db.h]),
++ [BDB_INC="-I/usr/include/db"],
++ AC_MSG_ERROR([No <db.h> include file is found. Install the
++ appropriate db*-devel package first.]))
++ BDB_LIB="-ldb"
++ AC_SUBST(BDB_INC)
++ AC_SUBST(BDB_LIB)
++ LIBS="${LIBS} ${BDB_LIB}"
++ CPPFLAGS="${CPPFLAGS} ${BDB_INC}"
++ AC_DEFINE(HAVE_BDB,[],[Build in Berkeley DB support?])
+ ;;
+ esac
+-
+-if test "$use_berkeley" != "no"; then
+- CYRUS_BERKELEY_DB_CHK()
+-
+- if test "$dblib" = "no"; then
+- AC_MSG_ERROR([Berkeley DB 3.x or later was not found. You may need to
+- supply the --with-bdb-libdir or --with-bdb-incdir configure options.])
+- fi
+-
+- if test "$with_bdb_lib" != "none"; then
+- CMU_ADD_LIBPATH($with_bdb_lib)
+- fi
+-
+- BDB_INC=${BDB_INCADD}
+- BDB_LIB=${BDB_LIBADD}
+- AC_SUBST(BDB_INC)
+- AC_SUBST(BDB_LIB)
+-
+- LIBS="${LIBS} ${BDB_LIBADD}"
+- CPPFLAGS="${BDB_INCADD} ${CPPFLAGS}"
+- AC_DEFINE(HAVE_BDB,[],[Build in Berkeley DB support?])
+-fi
+-AM_CONDITIONAL([USE_BERKELEY], [test "$use_berkeley" != "no"])
++AM_CONDITIONAL([USE_BERKELEY], [test "$with_bdb" != "no"])
+
+ dnl End Berkeley DB Detection
+
+@@ -1800,7 +1779,7 @@
+ pcre: $cyrus_cv_pcre_utf8
+
+ Database support:
+- bdb: $use_berkeley
++ bdb: $with_bdb
+ mysql: $with_mysql
+ postgresql: $use_pgsql
+ sqlite: $use_sqlite
diff --git a/net-mail/cyrus-imapd/files/cyrus-imapd-fix-tests.patch b/net-mail/cyrus-imapd/files/cyrus-imapd-fix-tests.patch
new file mode 100644
index 000000000000..c32f2065db00
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus-imapd-fix-tests.patch
@@ -0,0 +1,21 @@
+--- a/Makefile.am 2017-05-16 15:48:55.943709210 +0300
++++ b/Makefile.am 2017-05-16 15:50:20.950184710 +0300
+@@ -635,7 +635,6 @@
+ cunit/guid.testc \
+ cunit/hash.testc \
+ cunit/imapurl.testc \
+- cunit/jmapauth.testc \
+ cunit/libconfig.testc \
+ cunit/mboxname.testc \
+ cunit/md5.testc \
+@@ -654,6 +653,10 @@
+ cunit_TESTS += cunit/sieve.testc
+ endif
+
++if JMAP
++cunit_TESTS += cunit/jmapauth.testc
++endif
++
+ cunit_TESTS += \
+ cunit/spool.testc \
+ cunit/squat.testc \
diff --git a/net-mail/cyrus-imapd/files/cyrus-imapd-libcap-libs.patch b/net-mail/cyrus-imapd/files/cyrus-imapd-libcap-libs.patch
new file mode 100644
index 000000000000..e1f5332c6e83
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus-imapd-libcap-libs.patch
@@ -0,0 +1,35 @@
+--- a/configure.ac 2017-07-15 07:26:38.375295969 +0200
++++ b/configure.ac 2017-07-15 07:28:33.250194410 +0200
+@@ -1351,7 +1351,9 @@
+ AC_CHECK_HEADERS([sys/capability.h sys/prctl.h], , have_libcap=no)
+ if test "$have_libcap" = "yes"; then
+ AC_DEFINE(HAVE_LIBCAP, [], [Do we have libcap system capabilities handling (Linux systems only)?])
+- LIBS="$LIBS -lcap"
++ LIBCAP="-lcap"
++ AC_SUBST(LIBCAP)
++ LIBS="$LIBS $LIBCAP"
+ fi
+ fi
+ ;;
+--- a/perl/imap/Makefile.PL.in 2017-07-15 07:28:49.886034889 +0200
++++ b/perl/imap/Makefile.PL.in 2017-07-15 07:29:10.621836046 +0200
+@@ -90,7 +90,7 @@
+ 'clean' => {'FILES' => 'libcyrperl.a cyradm'},
+ 'OBJECT' => 'IMAP.o',
+ 'MYEXTLIB' => '@top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
+- 'LIBS' => [ "$LIB_SASL @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ @ZLIB@ @PCRE_LIBS@ @SQLITE_LIBADD@"],
++ 'LIBS' => [ "$LIB_SASL @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ @ZLIB@ @PCRE_LIBS@ @SQLITE_LIBADD@ @LIBCAP@"],
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I@top_srcdir@ -I@top_srcdir@/com_err/et @SASLFLAGS@ @SSL_CPPFLAGS@ -I@top_srcdir@/perl/imap",
+ 'EXE_FILES' => [cyradm],
+--- a/perl/sieve/managesieve/Makefile.PL.in 2017-07-15 07:29:29.433655659 +0200
++++ b/perl/sieve/managesieve/Makefile.PL.in 2017-07-15 07:29:44.593510288 +0200
+@@ -69,7 +69,7 @@
+ 'ABSTRACT' => 'Cyrus Sieve management interface',
+ 'VERSION_FROM' => "@top_srcdir@/perl/sieve/managesieve/managesieve.pm", # finds $VERSION
+ 'MYEXTLIB' => '../lib/.libs/libisieve.a @top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
+- 'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ @ZLIB@ @PCRE_LIBS@ @SQLITE_LIBADD@"],
++ 'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ @ZLIB@ @PCRE_LIBS@ @SQLITE_LIBADD@ @LIBCAP@"],
+ 'CCFLAGS' => '@GCOV_CFLAGS@',
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I@top_srcdir@/lib -I@top_srcdir@/perl/sieve -I@top_srcdir@/perl/sieve/lib @SASLFLAGS@ @SSL_CPPFLAGS@",
diff --git a/net-mail/cyrus-imapd/files/cyrus-imapd-sieve-libs-v4.patch b/net-mail/cyrus-imapd/files/cyrus-imapd-sieve-libs-v4.patch
new file mode 100644
index 000000000000..4a7bac2e3c1f
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus-imapd-sieve-libs-v4.patch
@@ -0,0 +1,127 @@
+--- a/configure.ac 2017-04-20 04:21:48.000000000 +0300
++++ b/configure.ac 2017-05-16 10:30:37.337965921 +0300
+@@ -666,7 +666,9 @@
+ fi
+
+ if test "$cyrus_cv_pcre_utf8" = "yes"; then
+- LIBS="$LIBS -lpcre -lpcreposix";
++ PCRE_LIBS="-lpcre -lpcreposix"
++ AC_SUBST(PCRE_LIBS)
++ LIBS="$LIBS $PCRE_LIBS"
+ AC_DEFINE(ENABLE_REGEX, [], [Do we have a regex library?])
+ AC_DEFINE(HAVE_PCREPOSIX_H, [], [Do we have usable pcre library?])
+ else
+@@ -1938,6 +1940,7 @@
+ fi
+
+ LIBS="${LIBS} ${SQLITE_LIBADD}"
++ AC_SUBST(SQLITE_LIBADD)
+ CPPFLAGS="${SQLITE_INCADD} ${CPPFLAGS}"
+ AC_DEFINE(HAVE_SQLITE,[],[Build in SQLite support?])
+ else
+--- a/perl/imap/Makefile.PL.in 2017-04-07 08:31:10.000000000 +0300
++++ b/perl/imap/Makefile.PL.in 2017-05-16 10:26:08.193965921 +0300
+@@ -90,7 +90,7 @@
+ 'clean' => {'FILES' => 'libcyrperl.a cyradm'},
+ 'OBJECT' => 'IMAP.o',
+ 'MYEXTLIB' => '@top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
+- 'LIBS' => [ "$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@"],
++ 'LIBS' => [ "$LIB_SASL @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ @ZLIB@ @PCRE_LIBS@ @SQLITE_LIBADD@"],
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I@top_srcdir@ -I@top_srcdir@/com_err/et @SASLFLAGS@ @SSL_CPPFLAGS@ -I@top_srcdir@/perl/imap",
+ 'EXE_FILES' => [cyradm],
+--- a/perl/sieve/managesieve/Makefile.PL.in 2017-04-07 08:31:10.000000000 +0300
++++ b/perl/sieve/managesieve/Makefile.PL.in 2017-05-16 10:26:31.048965921 +0300
+@@ -69,7 +69,7 @@
+ 'ABSTRACT' => 'Cyrus Sieve management interface',
+ 'VERSION_FROM' => "@top_srcdir@/perl/sieve/managesieve/managesieve.pm", # finds $VERSION
+ 'MYEXTLIB' => '../lib/.libs/libisieve.a @top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
+- 'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@"],
++ 'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ @ZLIB@ @PCRE_LIBS@ @SQLITE_LIBADD@"],
+ 'CCFLAGS' => '@GCOV_CFLAGS@',
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "-I@top_srcdir@/lib -I@top_srcdir@/perl/sieve -I@top_srcdir@/perl/sieve/lib @SASLFLAGS@ @SSL_CPPFLAGS@",
+--- a/configure.ac 2017-05-16 15:18:23.648756211 +0300
++++ b/configure.ac 2017-05-16 15:26:49.241756211 +0300
+@@ -633,8 +633,6 @@
+
+ AC_ARG_ENABLE(sieve,
+ [AS_HELP_STRING([--disable-sieve], [disable Sieve support])],,[enable_sieve="yes";])
+-AC_ARG_ENABLE(pcre,
+- [AS_HELP_STRING([--disable-pcre], [disable PCRE library])])
+
+ if test "$enable_sieve" != "no"; then
+ AC_DEFINE(USE_SIEVE,[],[Build in Sieve support?])
+@@ -650,42 +648,46 @@
+ if test -z "$ac_cv_prog_LEX"; then
+ AC_MSG_ERROR([Sieve requires flex/lex, but none is installed])
+ fi
++fi
++AM_CONDITIONAL([SIEVE], [test "${enable_sieve}" != "no"])
++
+
+- if test "$enable_pcre" != "no"; then
+- AC_CHECK_HEADER(pcreposix.h)
+- if test "$ac_cv_header_pcreposix_h" = "yes"; then
+- AC_MSG_CHECKING(for utf8 enabled pcre)
+- AC_CACHE_VAL(cyrus_cv_pcre_utf8, AC_TRY_CPP([#include <pcreposix.h>
++AC_ARG_ENABLE(pcre,
++ [AS_HELP_STRING([--disable-pcre], [disable PCRE library])])
++
++if test "$enable_pcre" != "no"; then
++ AC_CHECK_HEADER(pcreposix.h)
++ if test "$ac_cv_header_pcreposix_h" = "yes"; then
++ AC_MSG_CHECKING(for utf8 enabled pcre)
++ AC_CACHE_VAL(cyrus_cv_pcre_utf8, AC_TRY_CPP([#include <pcreposix.h>
+ #ifndef REG_UTF8
+ #include </nonexistent>
+ #endif],cyrus_cv_pcre_utf8=yes,cyrus_cv_pcre_utf8=no))
+- AC_MSG_RESULT($cyrus_cv_pcre_utf8)
+- else
+- cyrus_cv_pcre_utf8="no"
+- fi
++ AC_MSG_RESULT($cyrus_cv_pcre_utf8)
++ else
++ cyrus_cv_pcre_utf8="no"
+ fi
++fi
+
+- if test "$cyrus_cv_pcre_utf8" = "yes"; then
+- PCRE_LIBS="-lpcre -lpcreposix"
+- AC_SUBST(PCRE_LIBS)
+- LIBS="$LIBS $PCRE_LIBS"
+- AC_DEFINE(ENABLE_REGEX, [], [Do we have a regex library?])
+- AC_DEFINE(HAVE_PCREPOSIX_H, [], [Do we have usable pcre library?])
++if test "$cyrus_cv_pcre_utf8" = "yes"; then
++ PCRE_LIBS="-lpcre -lpcreposix"
++ AC_SUBST(PCRE_LIBS)
++ LIBS="$LIBS $PCRE_LIBS"
++ AC_DEFINE(ENABLE_REGEX, [], [Do we have a regex library?])
++ AC_DEFINE(HAVE_PCREPOSIX_H, [], [Do we have usable pcre library?])
++else
++ AC_CHECK_HEADERS(rxposix.h)
++ if test "$ac_cv_header_rxposix_h" = "yes"; then
++ LIBS="$LIBS -lrx"
++ AC_DEFINE(ENABLE_REGEX, [],
++ [Do we have a regex library?])
+ else
+- AC_CHECK_HEADERS(rxposix.h)
+- if test "$ac_cv_header_rxposix_h" = "yes"; then
+- LIBS="$LIBS -lrx"
+- AC_DEFINE(ENABLE_REGEX, [],
+- [Do we have a regex library?])
+- else
+- AC_SEARCH_LIBS(regcomp, regex,
+- AC_DEFINE(ENABLE_REGEX, [],
+- [Do we have a regex library?]), [])
+- fi
++ AC_SEARCH_LIBS(regcomp, regex,
++ AC_DEFINE(ENABLE_REGEX, [],
++ [Do we have a regex library?]), [])
+ fi
+ fi
+
+-AM_CONDITIONAL([SIEVE], [test "${enable_sieve}" != "no"])
+
+ dnl look for an option to disable sign-comparison warnings (needed for
+ dnl flex-generated sieve sources when building with -Werror)
diff --git a/net-mail/cyrus-imapd/files/cyrus-imapd-sieve-libs.patch b/net-mail/cyrus-imapd/files/cyrus-imapd-sieve-libs.patch
new file mode 100644
index 000000000000..0bfdc1d31550
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus-imapd-sieve-libs.patch
@@ -0,0 +1,43 @@
+--- a/configure.ac 2016-10-17 23:01:04.000000000 +0200
++++ b/configure.ac 2016-12-28 02:42:37.936610002 +0100
+@@ -400,6 +379,7 @@
+ fi
+
+ LIBS="${LIBS} ${SQLITE_LIBADD}"
++ AC_SUBST(SQLITE_LIBADD)
+ CPPFLAGS="${SQLITE_INCADD} ${CPPFLAGS}"
+
+ AC_DEFINE(HAVE_SQLITE,[],[Build in SQLite support?])
+@@ -437,7 +416,9 @@
+ fi
+
+ if test "$cyrus_cv_pcre_utf8" = "yes"; then
+- LIBS="$LIBS -lpcre -lpcreposix";
++ PCRE_LIBS="-lpcre -lpcreposix"
++ AC_SUBST(PCRE_LIBS)
++ LIBS="$LIBS $PCRE_LIBS"
+ AC_DEFINE(ENABLE_REGEX, [], [Do we have a regex library?])
+ AC_DEFINE(HAVE_PCREPOSIX_H, [], [Do we have usable pcre library?])
+ else
+--- a/perl/imap/Makefile.PL.in 2016-10-17 23:01:04.000000000 +0200
++++ b/perl/imap/Makefile.PL.in 2016-12-28 02:42:04.559449967 +0100
+@@ -69,7 +69,7 @@
+ 'clean' => {'FILES' => 'libcyrperl.a cyradm'},
+ 'OBJECT' => 'IMAP.o',
+ 'MYEXTLIB' => '@top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
+- 'LIBS' => [ "@BDB_LIB@ $LIB_SASL @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ @ZLIB@"],
++ 'LIBS' => [ "@BDB_LIB@ $LIB_SASL @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ @ZLIB@ @PCRE_LIBS@ @SQLITE_LIBADD@"],
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "@BDB_INC@ -I@top_srcdir@ -I@top_srcdir@/com_err/et @SASLFLAGS@ @SSL_CPPFLAGS@ -I@top_srcdir@/perl/imap",
+ 'EXE_FILES' => [cyradm],
+--- a/perl/sieve/managesieve/Makefile.PL.in 2016-10-17 23:01:04.000000000 +0200
++++ b/perl/sieve/managesieve/Makefile.PL.in 2016-12-28 02:42:34.496490437 +0100
+@@ -52,7 +52,7 @@
+ 'ABSTRACT' => 'Cyrus Sieve management interface',
+ 'VERSION_FROM' => "@top_srcdir@/perl/sieve/managesieve/managesieve.pm", # finds $VERSION
+ 'MYEXTLIB' => '../lib/libisieve.a @top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
+- 'LIBS' => ["@BDB_LIB@ $LIB_SASL @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ @ZLIB@"],
++ 'LIBS' => ["@BDB_LIB@ $LIB_SASL @SSL_LIBS@ @LIB_RT@ @LIB_UUID@ @ZLIB@ @PCRE_LIBS@ @SQLITE_LIBADD@"],
+ 'CCFLAGS' => '@COV_CFLAGS@',
+ 'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => "@BDB_INC@ -I@top_srcdir@/lib -I@top_srcdir@/perl/sieve/lib @SASLFLAGS@ @SSL_CPPFLAGS@",
diff --git a/net-mail/cyrus-imapd/files/cyrus.conf b/net-mail/cyrus-imapd/files/cyrus.conf
new file mode 100644
index 000000000000..ab084d51a024
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus.conf
@@ -0,0 +1,41 @@
+# Standard standalone server configuration.
+
+START {
+ # Do not delete this entry!
+ recover cmd="ctl_cyrusdb -r"
+
+ # This is only necessary if using idled for IMAP IDLE.
+ #idled cmd="idled"
+}
+
+# UNIX sockets start with a slash and are put into /var/imap/socket.
+SERVICES {
+ # Add or remove based on preferences.
+ imap cmd="imapd" listen="imap2" prefork=0
+ pop3 cmd="pop3d" listen="pop-3" prefork=0
+
+ # Don't forget to generate the needed keys for SSL or TLS
+ # (see doc/html/install-configure.html).
+ #imaps cmd="imapd -s" listen="imaps" prefork=0
+ #pop3s cmd="pop3d -s" listen="pop3s" prefork=0
+
+ sieve cmd="timsieved" listen="sieve" prefork=0
+
+ # at least one LMTP is required for delivery
+ #lmtp cmd="lmtpd" listen="lmtp" prefork=0
+ lmtpunix cmd="lmtpd" listen="/var/imap/socket/lmtp" prefork=0
+
+ # this is only necessary if using notifications
+ #notify cmd="notifyd" listen="/var/imap/socket/notify" proto="udp" prefork=1
+}
+
+EVENTS {
+ # This is required.
+ checkpoint cmd="ctl_cyrusdb -c" period=30
+
+ # This is only necessary if using duplicate delivery suppression.
+ delprune cmd="ctl_deliver -E 3" period=1440
+
+ # This is only necessary if caching TLS sessions.
+ tlsprune cmd="tls_prune" period=1440
+}
diff --git a/net-mail/cyrus-imapd/files/cyrus.confd b/net-mail/cyrus-imapd/files/cyrus.confd
new file mode 100644
index 000000000000..b11c6780bdc4
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus.confd
@@ -0,0 +1,5 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Additional options for the cyrus master
+CYRUS_OPTS=""
diff --git a/net-mail/cyrus-imapd/files/cyrus.pam-include b/net-mail/cyrus-imapd/files/cyrus.pam-include
new file mode 100644
index 000000000000..6e47645bd7d6
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus.pam-include
@@ -0,0 +1,6 @@
+#%PAM-1.0
+
+auth required pam_nologin.so
+auth include system-auth
+
+account include system-auth
diff --git a/net-mail/cyrus-imapd/files/cyrus.rc6 b/net-mail/cyrus-imapd/files/cyrus.rc6
new file mode 100644
index 000000000000..119de24c188c
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus.rc6
@@ -0,0 +1,22 @@
+#!/sbin/openrc-run
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use net
+ use dns logger
+ after drac saslauthd
+}
+
+start() {
+ ebegin "Starting cyrus imapd"
+ start-stop-daemon --start --quiet --background \
+ --exec /usr/lib/cyrus/master -- ${CYRUS_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cyrus imapd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/cyrus-master.pid
+ eend $?
+}
diff --git a/net-mail/cyrus-imapd/files/cyrus.rc7 b/net-mail/cyrus-imapd/files/cyrus.rc7
new file mode 100644
index 000000000000..348b01c04921
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus.rc7
@@ -0,0 +1,22 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use net
+ use dns logger
+ after drac saslauthd
+}
+
+start() {
+ ebegin "Starting cyrus imapd"
+ start-stop-daemon --start --quiet --background \
+ --exec /usr/libexec/cyrusmaster -- ${CYRUS_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cyrus imapd"
+ start-stop-daemon --stop --quiet --pidfile /run/cyrus-master.pid
+ eend $?
+}
diff --git a/net-mail/cyrus-imapd/files/cyrus.rc8 b/net-mail/cyrus-imapd/files/cyrus.rc8
new file mode 100644
index 000000000000..9d9e9452f565
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/cyrus.rc8
@@ -0,0 +1,34 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use net
+ use dns logger
+ after drac saslauthd
+}
+
+checkdirs() {
+ for dir in /run/cyrus/{,proc,lock,socket,sync}
+ do
+ checkpath -q -d -o cyrus:mail -m 0750 "${dir}" || {
+ eerror "Failed to create directory at $dir"
+ return 1
+ }
+ done
+}
+
+
+start() {
+ checkdirs || return 1
+ ebegin "Starting cyrus imapd"
+ start-stop-daemon --start --quiet --background \
+ --exec /usr/libexec/cyrusmaster -- ${CYRUS_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cyrus imapd"
+ start-stop-daemon --stop --quiet --pidfile /run/cyrus-master.pid
+ eend $?
+}
diff --git a/net-mail/cyrus-imapd/files/imapd.conf b/net-mail/cyrus-imapd/files/imapd.conf
new file mode 100644
index 000000000000..e77ff2f4b887
--- /dev/null
+++ b/net-mail/cyrus-imapd/files/imapd.conf
@@ -0,0 +1,50 @@
+# Don't forget to use chattr +S (if you are using ext[23])
+# when you change these directories (read the docs).
+configdirectory: /var/imap
+partition-default: /var/spool/imap
+sievedir: /var/imap/sieve
+
+tls_ca_path: /etc/ssl/certs
+tls_cert_file: /etc/ssl/cyrus/server.crt
+tls_key_file: /etc/ssl/cyrus/server.key
+
+# Don't use an everyday user as admin.
+admins: cyrus
+
+hashimapspool: yes
+allowanonymouslogin: no
+allowplaintext: no
+
+# Allow renaming of top-level mailboxes.
+#allowusermoves: yes
+
+# Use this if sieve-scripts could be in ~user/.sieve.
+#sieveusehomedir: yes
+
+# Use saslauthd if you want to use pam for imap.
+# But be warned: login with DIGEST-MD5 or CRAM-MD5
+# is not possible using pam.
+#sasl_pwcheck_method: saslauthd
+
+####################################################
+## This is a recommended authentication method if you
+## emerge cyrus-sasl with 'postgres' or 'mysql'
+## To use with mysql database uncomment those lines below.
+
+#sasl_pwcheck_method: auxprop
+#sasl_auxprop_plugin: sql
+
+## possible values for sasl_auxprop_plugin 'mysql', 'pgsql', 'sqlite'.
+#sasl_sql_engine: mysql
+
+## all possible values.
+#sasl_mech_list: LOGIN PLAIN CRAM-MD5 DIGEST-MD5 NTLM
+## or limit to CRAM-MD5 only
+#sasl_mech_list: CRAM-MD5
+
+## change below to suit your setup.
+sasl_sql_user: mailsqluser
+sasl_sql_passwd: password
+sasl_sql_database: mailsqldb
+sasl_sql_hostnames: localhost
+sasl_sql_select: SELECT clear FROM users WHERE email = '%u@%r'