summaryrefslogtreecommitdiff
path: root/net-mail/fdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-mail/fdm
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-mail/fdm')
-rw-r--r--net-mail/fdm/Manifest1
-rw-r--r--net-mail/fdm/fdm-2.0-r1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-mail/fdm/Manifest b/net-mail/fdm/Manifest
index b9f03df539aa..1d80bf888855 100644
--- a/net-mail/fdm/Manifest
+++ b/net-mail/fdm/Manifest
@@ -1,3 +1,4 @@
DIST fdm-2.0.tar.gz 313596 BLAKE2B 8b323f4a8953a46773a4e5a1214444dc97db4346f50990fcfb4c9d79ae40bbb73b61e3bf41bc95b76e44f6bed7b398cb210d58901823752e92ca7b83189cbc7e SHA512 14e923202d17083ceb3b91b3a442d7e512c37f3d29535f22d8c0c4e1d57c97acc5d5465d643ed0cf437b3945ef777a6e38da3117219c2d54dcec88ecab1e10d9
+EBUILD fdm-2.0-r1.ebuild 965 BLAKE2B 2832f7dabcda7b45e66193cbc4da645712318b98712f7859d099bb83c8552d3dd06d2d7a8cd9cb5cd47af84b2ae7c43322a2ef9cf492daf72c83578f4866359f SHA512 335a074dc6f41ce0f8a04a006146eb897eca716a3fd5a5af0335c5e6ec37b48f6fa9c49829ae4377ff447debaba5a31eaa7ec9dcd1c5273b1f9f9f80dfc9f95e
EBUILD fdm-2.0.ebuild 841 BLAKE2B 90dae6ba8dcfa5a2f9552fd90ce1b94f0816f743a2290afe00381554e34f4dd1c53d1ea5927e9699a82c3fb73751cdf8a83bcad20e28f2675f9b84abfd554921 SHA512 3f94f2ac469eb96c0d14b2568adb5a121aeed43c93bc2ba620803e167a533376cc5d05465e3cab54227f5f39a2d1d40739febe061e0843cb9a2ea4a180c4aa1f
MISC metadata.xml 295 BLAKE2B 258b3dde768bd93f75108c451644287a850dd28a867429953e65ce650dd9911982f6c47672d6fe75d67f572d28f6d6e3d15393f7e88f9beff7917dea30f53ca4 SHA512 702eb19cdd97836f450877ec4fb366447b32b5eb4c181930c0960b1d5c2638ba1a0c995cb599fa272fd31c80b5ecba93ba4b713d9e913103d5509ba2959f8eb6
diff --git a/net-mail/fdm/fdm-2.0-r1.ebuild b/net-mail/fdm/fdm-2.0-r1.ebuild
new file mode 100644
index 000000000000..4e24d3c741f9
--- /dev/null
+++ b/net-mail/fdm/fdm-2.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="fetch, filter and deliver mail"
+HOMEPAGE="https://github.com/nicm/fdm"
+SRC_URI="https://github.com/nicm/fdm/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples libressl pcre"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/tdb
+ pcre? ( dev-libs/libpcre )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/fdm
+ acct-user/fdm
+"
+
+DOCS=( CHANGES README TODO MANUAL )
+
+src_prepare() {
+ default
+
+ # Change user '_fdm' to 'fdm'
+ sed -e 's/_fdm/fdm/g' -i fdm.h || die
+}
+
+src_configure() {
+ econf $(use_enable pcre)
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ fi
+}
+
+pkg_preinst() {
+ # This user is hard-coded in fdm.h. If fdm is started as root,
+ # it will attempt to drop privileges (to this user).
+ enewuser _fdm
+}