summaryrefslogtreecommitdiff
path: root/net-mail/isync/isync-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-08 01:07:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-08 01:07:24 +0100
commite3cf2c86fca1750343c1885311f857f185ee4f2d (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /net-mail/isync/isync-1.3.1.ebuild
parentf1af93971b7490792d8541bc790e0d8c6d787059 (diff)
gentoo resync : 08.09.2019
Diffstat (limited to 'net-mail/isync/isync-1.3.1.ebuild')
-rw-r--r--net-mail/isync/isync-1.3.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-mail/isync/isync-1.3.1.ebuild b/net-mail/isync/isync-1.3.1.ebuild
new file mode 100644
index 000000000000..a9663859bf83
--- /dev/null
+++ b/net-mail/isync/isync-1.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="MailDir mailbox synchronizer"
+HOMEPAGE="http://isync.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/${PN}/${PN}"
+ inherit git-r3 autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+IUSE="libressl sasl ssl zlib"
+
+RDEPEND="
+ >=sys-libs/db-4.2:=
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ zlib? ( sys-libs/zlib:0= )
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+"
+
+src_prepare () {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure () {
+ econf \
+ $(use_with ssl) \
+ $(use_with sasl) \
+ $(use_with zlib)
+}