summaryrefslogtreecommitdiff
path: root/net-mail/mailshears/mailshears-0.0.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /net-mail/mailshears/mailshears-0.0.3-r2.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'net-mail/mailshears/mailshears-0.0.3-r2.ebuild')
-rw-r--r--net-mail/mailshears/mailshears-0.0.3-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-mail/mailshears/mailshears-0.0.3-r2.ebuild b/net-mail/mailshears/mailshears-0.0.3-r2.ebuild
new file mode 100644
index 000000000000..3528190a0c78
--- /dev/null
+++ b/net-mail/mailshears/mailshears-0.0.3-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25"
+
+# The tests are dangerous and shouldn't be run by anyone!
+# They mess with your local postgres databases.
+RUBY_FAKEGEM_RECIPE_TEST=none
+RUBY_FAKEGEM_RECIPE_DOC=yard
+RUBY_FAKEGEM_EXTRADOC="doc/${PN}.example.conf.yml"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mangle your mail garden"
+HOMEPAGE="http://michael.orlitzky.com/code/mailshears.xhtml"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/pg-0.17 <dev-ruby/pg-1"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman "doc/man1/${PN}.1"
+}