summaryrefslogtreecommitdiff
path: root/net-mail/mailshears/mailshears-0.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-mail/mailshears/mailshears-0.0.5.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-mail/mailshears/mailshears-0.0.5.ebuild')
-rw-r--r--net-mail/mailshears/mailshears-0.0.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-mail/mailshears/mailshears-0.0.5.ebuild b/net-mail/mailshears/mailshears-0.0.5.ebuild
new file mode 100644
index 000000000000..06a584f9a770
--- /dev/null
+++ b/net-mail/mailshears/mailshears-0.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ruby31 is ok too
+USE_RUBY="ruby26 ruby27 ruby30"
+
+# The tests are dangerous and shouldn't be run by anyone!
+# They mess with your local postgres databases.
+RUBY_FAKEGEM_RECIPE_TEST=none
+RUBY_FAKEGEM_RECIPE_DOC=yard
+RUBY_FAKEGEM_EXTRADOC="doc/${PN}.example.conf.yml"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mangle your mail garden"
+HOMEPAGE="http://michael.orlitzky.com/code/mailshears.xhtml"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/pg-1.2 <dev-ruby/pg-2"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman "doc/man1/${PN}.1"
+}