summaryrefslogtreecommitdiff
path: root/net-mail/mboxgrep/mboxgrep-0.7.9-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-18 07:00:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-18 07:00:16 +0100
commitdcb9c4187a31b8b770600503289d2ad39745e782 (patch)
tree423501e7d184dee011a7c99629d0e357d6bd64be /net-mail/mboxgrep/mboxgrep-0.7.9-r3.ebuild
parent5e0a5ca921524f8859808527a57655eec16efa52 (diff)
gentoo auto-resync : 18:07:2023 - 07:00:16
Diffstat (limited to 'net-mail/mboxgrep/mboxgrep-0.7.9-r3.ebuild')
-rw-r--r--net-mail/mboxgrep/mboxgrep-0.7.9-r3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-mail/mboxgrep/mboxgrep-0.7.9-r3.ebuild b/net-mail/mboxgrep/mboxgrep-0.7.9-r3.ebuild
new file mode 100644
index 000000000000..989483a407a7
--- /dev/null
+++ b/net-mail/mboxgrep/mboxgrep-0.7.9-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools
+
+DESCRIPTION="Grep for mbox files"
+SRC_URI="mirror://sourceforge/mboxgrep/${P}.tar.gz"
+HOMEPAGE="https://datatipp.se/mboxgrep/"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dmalloc"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-libs/libpcre
+ sys-libs/zlib
+ dmalloc? ( dev-libs/dmalloc )
+"
+DEPEND="
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-_DEFAULT_SOURCE.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${PN}-0.7.9-musl-missing-strcmp.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with dmalloc dmalloc $(usex dmalloc yes no))
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ mandir="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
+ install
+ dodoc ChangeLog NEWS TODO README
+}