summaryrefslogtreecommitdiff
path: root/net-mail/notmuch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /net-mail/notmuch
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'net-mail/notmuch')
-rw-r--r--net-mail/notmuch/Manifest3
-rw-r--r--net-mail/notmuch/notmuch-0.29.1-r1.ebuild237
-rw-r--r--net-mail/notmuch/notmuch-0.29.1.ebuild9
3 files changed, 247 insertions, 2 deletions
diff --git a/net-mail/notmuch/Manifest b/net-mail/notmuch/Manifest
index 2ac172ef50dc..7f4af32582db 100644
--- a/net-mail/notmuch/Manifest
+++ b/net-mail/notmuch/Manifest
@@ -6,5 +6,6 @@ DIST database-v1.tar.xz 204876 BLAKE2B 846a8d2f17edb61ed1c3d3c655becd1f60b404677
DIST notmuch-0.28.4.tar.gz 922364 BLAKE2B f22d52ecc982b086b5d2a67d3b9ae4a379bdcb9e9acf3e77060fd7d97439347e3b4cd767f2c9c3c48657b80f63316f6abc09a653d6791e27b4a8996adccf42a9 SHA512 77d7ad81e1f7dc93ae6392346da434f6dc74c21d19be728c2a6ca283c429f36e7081387d223af58eb5f63f5d2a8ad8367f0103f0bb9d052890c07fe419abbee7
DIST notmuch-0.29.1.tar.xz 660352 BLAKE2B d145aba2d1a376e8cbcff3d51f9a7093649912a54273f91cce2a56fb414e222c2bbf0aeb510894278bf7dca8a96412400d55897a4d42281ab9c110d9bc8207a6 SHA512 9b76a7c8c62cb67b64a0008f80a82eeecccd20267ddba67d4d96a768815466c305f154769947bb9526e02c7a1696faaf69e94b90007603b185589be0c7c2a5d8
EBUILD notmuch-0.28.4.ebuild 5090 BLAKE2B 8987d5ca0226b9a8093a3e1d0c48cbd24272a4f5aa1e41833ea9cd10cb02fed6199181116700cb0cb025301460397d5cca6300e7c33ddb84aac54c8476c332bd SHA512 971f6d3a84f360f8e4bfe161017fb79c58918610752344dff99bc9872fb303b14e172e2224e52c32130742b1e74e97ec879b5e1b0cef2a7e386b2f7eef4156b5
-EBUILD notmuch-0.29.1.ebuild 5038 BLAKE2B 75f4181ae4670d6019d4715255b451c28a3cec3e0a2dc27a7bdfd3b3e7ad88bdf25eda710deae7e90f583a1998e9769f30559574d2887bf1b32cc46008e315fd SHA512 f3beed9c567af5a0af98af8c46f497adf1f6400d42fe75abc968cdbe65f38869e9b07fb65fa1a00c7d42f38be18b124f60775d15933ecf8cc8a9ff993cd57b7d
+EBUILD notmuch-0.29.1-r1.ebuild 5197 BLAKE2B f847ac52b619bd10a4a294b27bf1149dc5c0309933c197eb17d2fa9c91dfa41036dad9c480afa1390c49cb062e4c12e897eb7f970552d91d2775c2797601bc22 SHA512 0ef0cd052e0704c155274dc7cf90eb7b28cd097bb4baaaa1dacf8c7228a17a7a6a1ed871512dd2379763722531e349b6d8d9387c4f39a84578b18d5d2c19223b
+EBUILD notmuch-0.29.1.ebuild 5215 BLAKE2B 13850458a70677d973331165accdac1884c4186bef74cef558dd32af43a9247f579cd0a5a2992fefd5c7a941aa7001564a585d0aecc823d4958fcf5ccaf1e3c5 SHA512 d6261d95f80d5c2ba8a04176b394ff58028e8caa0b7b25b9d95f63c7ab3061adc2e569eb8ac4432332ff5ec13c8ee038c500be832e5d7ee70d60475b0047bb89
MISC metadata.xml 1117 BLAKE2B 08710cbb42c20580235f5cfafa39715c33fb50de24cf98a182418db3c52ee1de5a1ee0e0775ae5756fee301c952995a1e7da52b9c13e5bd8c8b2fc0d1d74a5d2 SHA512 c420e475e5d16d35cceb1162c14eae143e5f539e771561d525af4ab0f0853e700b9a3209ee1a7aa9b4269c235737304c435d463cd8b1cf201402152ff0a6a4f3
diff --git a/net-mail/notmuch/notmuch-0.29.1-r1.ebuild b/net-mail/notmuch/notmuch-0.29.1-r1.ebuild
new file mode 100644
index 000000000000..0124be3ef9a2
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.29.1-r1.ebuild
@@ -0,0 +1,237 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
+ distutils-r1 toolchain-funcs
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="https://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.xz
+ test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
+
+LICENSE="GPL-3"
+# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
+# meant to be binary backward compatible.
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~x86 ~x64-solaris"
+REQUIRED_USE="
+ nmbug? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( crypt emacs python valgrind )
+ "
+IUSE="crypt doc emacs mutt nmbug python test valgrind"
+
+CDEPEND="
+ !!<app-shells/bash-completion-1.9
+ >=dev-libs/glib-2.22:2
+ >=dev-libs/gmime-3.0.3:3.0
+ >=dev-libs/xapian-1.4.8:=
+ dev-python/sphinx
+ sys-apps/texinfo
+ >=sys-libs/zlib-1.2.5.2
+ sys-libs/talloc
+ crypt? ( dev-libs/gmime:3.0[crypt] )
+ emacs? ( >=virtual/emacs-23 )
+ python? ( ${PYTHON_DEPS} )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+ test? (
+ app-misc/dtach
+ || ( >=app-editors/emacs-23[libxml2] >=app-editors/emacs-vcs-23[libxml2] )
+ sys-devel/gdb
+ crypt? ( app-crypt/gnupg dev-libs/openssl )
+ )
+ valgrind? ( dev-util/valgrind )
+ "
+RDEPEND="${CDEPEND}
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git )
+ mutt? (
+ dev-perl/File-Which
+ dev-perl/Mail-Box
+ dev-perl/MailTools
+ dev-perl/String-ShellQuote
+ dev-perl/Term-ReadLine-Gnu
+ virtual/perl-Digest-SHA
+ virtual/perl-File-Path
+ virtual/perl-Getopt-Long
+ virtual/perl-Pod-Parser
+ )
+ "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+PATCHES=(
+ "${FILESDIR}"/${PV}-0001-Use-loopback-IP-address-rather-than-name.patch
+)
+
+bindings() {
+ local ret=0
+
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ "$@"
+ ret=$?
+ popd || die
+ fi
+
+ return $ret
+}
+
+pkg_pretend() {
+ if has_version '<net-mail/notmuch-0.18'; then
+ ewarn
+ ewarn "There are few not backward compatible changes between"
+ ewarn "<notmuch-0.18 and >=notmuch-0.18. See NEWS file"
+ ewarn "(0.18 section) for details before first use!"
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+}
+
+src_unpack() {
+ unpack "${P}".tar.xz
+ if use test; then
+ mkdir -p "${S}"/test/test-databases || die
+ cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ bindings python distutils-r1_src_prepare
+ bindings python mv README README-python || die
+ mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+
+ # assure that new Makefile.config will be generated
+ rm -f Makefile.config || die
+
+ sed -e 's@^install: all install-man install-info$@install: all install-info@' -i Makefile.local
+
+ if use test; then
+ append-cflags -g
+ append-cxxflags -g
+ fi
+
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ append-ldflags -lnsl -lsocket # non-autoconf configure
+ # disable gpgme test using too old gpg-key
+ sed -i \
+ -e '/GNUPGHOME=/d' \
+ -e '/SESSION_KEY =/c|| false ;' \
+ configure || die
+ fi
+}
+
+src_configure() {
+ python_setup # for sphinx
+
+ local myeconfargs=(
+ --bashcompletiondir="$(get_bashcompdir)"
+ --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
+ --without-desktop
+ --without-ruby
+ --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ $(use_with emacs)
+ $(use_with doc api-docs)
+ )
+ tc-export CC CXX
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ python_setup # for sphinx
+
+ V=1 default
+ bindings python distutils-r1_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ emake notmuch-mutt.1
+ popd || die
+ fi
+
+ if use doc; then
+ pydocs() {
+ pushd docs || die
+ emake html
+ rm -r html/_sources || die
+ rm html/{objects.inv,.buildinfo} || die
+ mkdir -p ../html && mv html ../html/python || die
+ popd || die
+ }
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+ fi
+}
+
+src_test() {
+ pax-mark -m notmuch
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" V=1 default
+ pax-mark -ze notmuch
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ doman doc/_build/man/man?/*.?
+ fi
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin devel/nmbug/nmbug
+ dobin devel/nmbug/notmuch-report
+ fi
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ dobin notmuch-mutt
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd || die
+ fi
+
+ DOCS="" bindings python distutils-r1_src_install
+ use doc && bindings python dodoc -r html
+}
+
+pkg_preinst() {
+ if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
+ elog "To enable notmuch support in mutt, add the following line into"
+ elog "your mutt config file, please:"
+ elog ""
+ elog " source /etc/mutt/notmuch-mutt.rc"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/net-mail/notmuch/notmuch-0.29.1.ebuild b/net-mail/notmuch/notmuch-0.29.1.ebuild
index ffa74708369a..4984cf17d69a 100644
--- a/net-mail/notmuch/notmuch-0.29.1.ebuild
+++ b/net-mail/notmuch/notmuch-0.29.1.ebuild
@@ -131,7 +131,14 @@ src_prepare() {
append-cxxflags -g
fi
- [[ ${CHOST} == *-solaris* ]] && append-ldflags -lnsl -lsocket
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ append-ldflags -lnsl -lsocket # non-autoconf configure
+ # disable gpgme test using too old gpg-key
+ sed -i \
+ -e '/GNUPGHOME=/d' \
+ -e '/SESSION_KEY =/c|| false ;' \
+ configure || die
+ fi
}
src_configure() {