summaryrefslogtreecommitdiff
path: root/net-mail/safecat/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
commit423d21dcfee183cc4b04d29c1621615e8c30f834 (patch)
tree23bd6110b9a77b8d679b5ab60fb7663b8627f698 /net-mail/safecat/files
parent81e4fbcb846ed1cabdad699c0029b166dd7273b7 (diff)
gentoo resync : 04.01.2018
Diffstat (limited to 'net-mail/safecat/files')
-rw-r--r--net-mail/safecat/files/safecat-1.13-head-tail-POSIX.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-mail/safecat/files/safecat-1.13-head-tail-POSIX.patch b/net-mail/safecat/files/safecat-1.13-head-tail-POSIX.patch
new file mode 100644
index 000000000000..59bd33b0f760
--- /dev/null
+++ b/net-mail/safecat/files/safecat-1.13-head-tail-POSIX.patch
@@ -0,0 +1,45 @@
+--- a/make-compile.sh
++++ b/make-compile.sh
+@@ -1 +1 @@
+-echo exec "$CC" "`head -1 conf-includes`" -c '${1+"$@"}'
++echo exec "$CC" "`head -n 1 conf-includes`" -c '${1+"$@"}'
+--- a/Makefile
++++ b/Makefile
+@@ -17,8 +17,8 @@
+ auto-ccld.sh: \
+ conf-cc conf-ld warn-auto.sh
+ ( cat warn-auto.sh; \
+- echo CC=\'`head -1 conf-cc`\'; \
+- echo LD=\'`head -1 conf-ld`\'; \
++ echo CC=\'`head -n 1 conf-cc`\'; \
++ echo LD=\'`head -n 1 conf-ld`\'; \
+ ) > auto-ccld.sh
+
+ auto-str: \
+@@ -31,7 +31,7 @@
+
+ auto_home.c: \
+ auto-str conf-root
+- ./auto-str auto_home `head -1 conf-root` > auto_home.c
++ ./auto-str auto_home `head -n 1 conf-root` > auto_home.c
+
+ auto_home.o: \
+ compile auto_home.c
+@@ -161,7 +161,7 @@
+ maildir: \
+ warn-auto.sh maildir.sh conf-root
+ cat warn-auto.sh maildir.sh \
+- | sed s}HOME}"`head -1 conf-root`"}g \
++ | sed s}HOME}"`head -n 1 conf-root`"}g \
+ > maildir
+ chmod 755 maildir
+
+@@ -407,7 +407,7 @@
+ version.h: \
+ conf-version
+ @echo 'static const char *const version_string="$$Version:' \
+- `head -1 conf-version` 'built' `date +"%b %d, %Y"` at \
++ `head -n 1 conf-version` 'built' `date +"%b %d, %Y"` at \
+ `date +"%H:%M"`'$$";' > version.h
+
+ writefile.o: \