summaryrefslogtreecommitdiff
path: root/net-mail/tpop3d/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/tpop3d/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/tpop3d/files')
-rw-r--r--net-mail/tpop3d/files/tpop3d-1.5.4-gold.patch20
-rw-r--r--net-mail/tpop3d/files/tpop3d-1.5.4.init29
2 files changed, 49 insertions, 0 deletions
diff --git a/net-mail/tpop3d/files/tpop3d-1.5.4-gold.patch b/net-mail/tpop3d/files/tpop3d-1.5.4-gold.patch
new file mode 100644
index 000000000000..149dc9430dd0
--- /dev/null
+++ b/net-mail/tpop3d/files/tpop3d-1.5.4-gold.patch
@@ -0,0 +1,20 @@
+commit 8ed9a7721a406fea7dfc7f0a5eb6e68f3d63a99e
+Author: Eray Aslan <eras@gentoo.org>
+Date: Fri Jun 3 13:52:55 2011 +0000
+
+ Fix linking against gold
+
+diff --git a/configure.in b/configure.in
+index ac16864..a260652 100644
+--- a/configure.in
++++ b/configure.in
+@@ -587,7 +587,8 @@ fi
+ # OpenSSL
+ if test x"$enable_tls" = x"yes" || test x"$enable_sha1_passwords" = x"yes"
+ then
+- AC_CHECK_LIB2(ssl, SSL_new, [], AC_MSG_ERROR([[TLS/SHA1 passwords enabled, but can't find libssl]]), -lcrypto)
++ AC_CHECK_LIB(ssl, SSL_new, [], AC_MSG_ERROR([[TLS/SHA1 passwords enabled, but can't find libssl]]))
++ AC_CHECK_LIB(crypto, SHA1_Init, [], AC_MSG_ERROR([[TLS/SHA1 passwords enabled, but can't find libcrypto]]))
+ fi
+
+ # GNU dbm
diff --git a/net-mail/tpop3d/files/tpop3d-1.5.4.init b/net-mail/tpop3d/files/tpop3d-1.5.4.init
new file mode 100644
index 000000000000..ad6243871d61
--- /dev/null
+++ b/net-mail/tpop3d/files/tpop3d-1.5.4.init
@@ -0,0 +1,29 @@
+#!/sbin/openrc-run
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /etc/tpop3d/tpop3d.conf ] ; then
+ eerror "You need an /etc/tpop3d/tpop3d.conf file to run tpop3d"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting tpop3d"
+ start-stop-daemon --start --quiet --background \
+ --exec /usr/sbin/tpop3d -- -f /etc/tpop3d/tpop3d.conf \
+ -p /var/run/tpop3d.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping tpop3d"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/tpop3d
+ eend $?
+}