summaryrefslogtreecommitdiff
path: root/net-mail/vqadmin/vqadmin-2.3.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/vqadmin/vqadmin-2.3.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/vqadmin/vqadmin-2.3.7.ebuild')
-rw-r--r--net-mail/vqadmin/vqadmin-2.3.7.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/net-mail/vqadmin/vqadmin-2.3.7.ebuild b/net-mail/vqadmin/vqadmin-2.3.7.ebuild
new file mode 100644
index 000000000000..5bbf2374db40
--- /dev/null
+++ b/net-mail/vqadmin/vqadmin-2.3.7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit webapp eutils autotools qmail
+
+DESCRIPTION="A web based control pannel to manage Virtual Qmail Domains. Works with qmailadmin"
+HOMEPAGE="http://www.inter7.com/index.php?page=vqadmin"
+SRC_URI="http://www.inter7.com/vqadmin/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/qmail
+ >=net-mail/vpopmail-5.3"
+RDEPEND="${DEPEND}
+ net-mail/qmailadmin"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fixes for sane webapp integration
+ sed -i \
+ -e "s|html/|/usr/share/${PN}/|g" \
+ -e "s|/images/vqadmin/|/vqadmin/|g" \
+ -e "s|/cgi-bin/vqadmin/|/cgi-bin/|g" \
+ -e "s|vqadmin\.cgi|vqadmin|g" \
+ *.h *.c html/*.html
+}
+
+src_compile() {
+ econf ${myopts} \
+ --enable-qmaildir="${QMAIL_HOME}" \
+ --enable-vpopuser=vpopmail \
+ --enable-vpopgroup=vpopmail \
+ --enable-cgibindir="${MY_CGIBINDIR}" \
+ || die "econf failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto /usr/share/${PN}
+ doins html/*
+
+ insinto "${MY_HTDOCSDIR}"
+ doins html/*.css
+
+ insinto "${MY_CGIBINDIR}"
+ doins vqadmin.acl
+ insopts -m 755
+ doins vqadmin
+
+ dodoc ACL AUTHORS BUGS ChangeLog FAQ INSTALL NEWS TODO README
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}