summaryrefslogtreecommitdiff
path: root/net-misc/arpd/arpd-0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
commit423d21dcfee183cc4b04d29c1621615e8c30f834 (patch)
tree23bd6110b9a77b8d679b5ab60fb7663b8627f698 /net-misc/arpd/arpd-0.2-r1.ebuild
parent81e4fbcb846ed1cabdad699c0029b166dd7273b7 (diff)
gentoo resync : 04.01.2018
Diffstat (limited to 'net-misc/arpd/arpd-0.2-r1.ebuild')
-rw-r--r--net-misc/arpd/arpd-0.2-r1.ebuild34
1 files changed, 21 insertions, 13 deletions
diff --git a/net-misc/arpd/arpd-0.2-r1.ebuild b/net-misc/arpd/arpd-0.2-r1.ebuild
index 788d227dc629..bd8fb5f5f32d 100644
--- a/net-misc/arpd/arpd-0.2-r1.ebuild
+++ b/net-misc/arpd/arpd-0.2-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
+EAPI=6
-inherit autotools eutils
+inherit autotools
-DESCRIPTION="ARP server which claims all unassigned addresses (for network monitoring or simulation)"
+DESCRIPTION="ARP server claiming all unassigned addresses (for network monitoring/simulation)"
HOMEPAGE="http://www.citi.umich.edu/u/provos/honeyd/"
SRC_URI="http://www.citi.umich.edu/u/provos/honeyd/${P}.tar.gz"
@@ -14,28 +14,36 @@ SLOT="0"
KEYWORDS="amd64 hppa ppc ~ppc64 sparc x86"
IUSE=""
-DEPEND=">=dev-libs/libdnet-1.4
+DEPEND="
+ >=dev-libs/libdnet-1.4
>=dev-libs/libevent-0.6
net-libs/libpcap
!sys-apps/iproute2"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${PN}
-src_prepare() {
- epatch "${FILESDIR}"/arpd.c.patch
- epatch "${FILESDIR}"/${P}-libevent.patch
+PATCHES=(
+ "${FILESDIR}"/arpd.c.patch
+ "${FILESDIR}"/${P}-libevent.patch
- #fix bug 337481, replace test on libevent.a with libevent.so
- epatch "${FILESDIR}"/${P}-buildsystem-libevent-test.patch
+ # bug 337481, replace test on libevent.a with libevent.so
+ "${FILESDIR}"/${P}-buildsystem-libevent-test.patch
+)
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
- econf --with-libdnet="${EPREFIX}"/usr --with-libevent="${EPREFIX}"/usr
+ econf \
+ --with-libdnet="${EPREFIX}"/usr \
+ --with-libevent="${EPREFIX}"/usr
}
src_install() {
- dosbin arpd || die
- doman arpd.8 || die
+ dosbin arpd
+ doman arpd.8
}