summaryrefslogtreecommitdiff
path: root/net-misc/arpd/arpd-0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/arpd/arpd-0.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/arpd/arpd-0.2-r1.ebuild')
-rw-r--r--net-misc/arpd/arpd-0.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/arpd/arpd-0.2-r1.ebuild b/net-misc/arpd/arpd-0.2-r1.ebuild
new file mode 100644
index 000000000000..788d227dc629
--- /dev/null
+++ b/net-misc/arpd/arpd-0.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="ARP server which claims all unassigned addresses (for network monitoring or simulation)"
+HOMEPAGE="http://www.citi.umich.edu/u/provos/honeyd/"
+SRC_URI="http://www.citi.umich.edu/u/provos/honeyd/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ~ppc64 sparc x86"
+IUSE=""
+
+DEPEND=">=dev-libs/libdnet-1.4
+ >=dev-libs/libevent-0.6
+ net-libs/libpcap
+ !sys-apps/iproute2"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/arpd.c.patch
+ epatch "${FILESDIR}"/${P}-libevent.patch
+
+ #fix bug 337481, replace test on libevent.a with libevent.so
+ epatch "${FILESDIR}"/${P}-buildsystem-libevent-test.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-libdnet="${EPREFIX}"/usr --with-libevent="${EPREFIX}"/usr
+}
+
+src_install() {
+ dosbin arpd || die
+ doman arpd.8 || die
+}