summaryrefslogtreecommitdiff
path: root/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/astmanproxy/astmanproxy-1.28.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/astmanproxy/astmanproxy-1.28.2.ebuild')
-rw-r--r--net-misc/astmanproxy/astmanproxy-1.28.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild b/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild
new file mode 100644
index 000000000000..73e1c6b42e1f
--- /dev/null
+++ b/net-misc/astmanproxy/astmanproxy-1.28.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit base multilib toolchain-funcs
+
+DESCRIPTION="Proxy for the Asterisk manager interface"
+HOMEPAGE="https://github.com/davies147/astmanproxy/"
+SRC_URI="https://github.com/davies147/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND=""
+PATCHES=( "${FILESDIR}/${P}-gentoo.diff" )
+
+src_prepare() {
+ base_src_prepare
+
+ # Fix multilib
+ sed -i -e "s#/usr/lib/#/usr/$(get_libdir)/#" "${S}/Makefile" \
+ || die "multilib sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}" \
+ LD="$(tc-getLD)" \
+ RAWLDFLAGS="$(raw-ldflags)"
+}
+
+src_install() {
+ dosbin astmanproxy
+
+ dodoc README VERSIONS
+
+ docinto samples
+ dodoc samples/*
+
+ insinto /etc/asterisk
+ doins configs/astmanproxy.conf
+ doins configs/astmanproxy.users
+
+ newinitd "${FILESDIR}"/astmanproxy.rc6 astmanproxy
+}