summaryrefslogtreecommitdiff
path: root/net-misc/axel/files/axel-2.4-buildsystem.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/axel/files/axel-2.4-buildsystem.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/axel/files/axel-2.4-buildsystem.patch')
-rw-r--r--net-misc/axel/files/axel-2.4-buildsystem.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-misc/axel/files/axel-2.4-buildsystem.patch b/net-misc/axel/files/axel-2.4-buildsystem.patch
new file mode 100644
index 000000000000..a1571f0fc576
--- /dev/null
+++ b/net-misc/axel/files/axel-2.4-buildsystem.patch
@@ -0,0 +1,23 @@
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 1c3863a..b43fcff 100644
+--- a/Makefile
++++ b/Makefile
+@@ -51,13 +51,13 @@ uninstall-etc:
+ ### MAIN PROGRAM
+
+ $(OUTFILE): axel.o conf.o conn.o ftp.o http.o search.o tcp.o text.o
+- $(CC) *.o -o $(OUTFILE) $(LFLAGS)
++ $(CC) $(LDFLAGS) *.o -o $(OUTFILE) $(LFLAGS)
+ ifndef DEBUG
+ -$(STRIP) $(OUTFILE)
+ endif
+
+ .c.o:
+- $(CC) -c $*.c -o $*.o -Wall $(CFLAGS)
++ $(CC) $(CPPFLAGS) -c $*.c -o $*.o -Wall $(CFLAGS)
+
+ install-bin:
+ mkdir -p $(DESTDIR)$(BINDIR)/