summaryrefslogtreecommitdiff
path: root/net-misc/casync
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
commit8c364c784966be1700ea39ae45028f3e9be9cae0 (patch)
treec1971211069b79e3831b71accd52a67a9fdc77a3 /net-misc/casync
parent6bd95d1f6320b8666a31ec949183aaa3088aa16f (diff)
gentoo resync : 27.03.2018
Diffstat (limited to 'net-misc/casync')
-rw-r--r--net-misc/casync/Manifest3
-rw-r--r--net-misc/casync/casync-2_p20180321.ebuild41
-rw-r--r--net-misc/casync/metadata.xml15
3 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/casync/Manifest b/net-misc/casync/Manifest
new file mode 100644
index 000000000000..75dbd9b5b62c
--- /dev/null
+++ b/net-misc/casync/Manifest
@@ -0,0 +1,3 @@
+DIST casync-2_p20180321.tar.gz 1306314 BLAKE2B 9fa9238a9677ede6a218c27929f0990fe26ad0afeeb2f736a6a665d301bde6c016e6fc0f3120266707d3c12cd765667f8a8cd231bb49b5cf8bedfc4ab812b481 SHA512 c8fd61e56dc3e0aec02656e28f8cec8d873498635bdaf96c0576ab3867a0e2ef0fb69206f3a476b0515a284ba35a2d746985056e522f5d396e35bc13fd81ae58
+EBUILD casync-2_p20180321.ebuild 979 BLAKE2B e2eace1e5ea878f96b6294238b0ee7a24ce226a50fd7c9e26ffc56b848879e45bf2450bc802da0d4c0843a3289dec40fcde5d44c35fc1d0111f21aff1264a9ec SHA512 6b67d64e5ad55aacffd3a716a4a1dad0ce5ec044f65d02239025637a2eba2f6633fb2aaabd8c799bb05a310811c3b9ccef780623dc1ba98f3a74f337f0b95c98
+MISC metadata.xml 438 BLAKE2B 8643d75302fb8fbd0a5451f562df8d3e342925a06c20aa4704c41482cfc54f9b9038a873c3df8b9536eb9b0e0908cc99fcf901cc645e8c0c02b278110d0c6108 SHA512 10d7359de3c2a9fe963fb5800d1d79822435e27c6abcb9a09011412396d95f0f1cfc9f565ebdf4cd82f2c63047c6e5493f7cf35bdb9ea134a590565cff2922b5
diff --git a/net-misc/casync/casync-2_p20180321.ebuild b/net-misc/casync/casync-2_p20180321.ebuild
new file mode 100644
index 000000000000..6303ac8dee3e
--- /dev/null
+++ b/net-misc/casync/casync-2_p20180321.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot meson
+
+COMMIT="a755da21d3ba5d9cbb002dfc86a3ab0d46b82176"
+DESCRIPTION=" Content-Addressable Data Synchronization Tool"
+HOMEPAGE="https://github.com/systemd/casync"
+SRC_URI="https://github.com/systemd/casync/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+fuse +udev man selinux test"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse:0 )
+ selinux? ( sys-libs/libselinux )
+ udev? ( virtual/libudev )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ man? ( dev-python/sphinx )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dfuse="$(usex fuse true false)"
+ -Dman="$(usex man true false)"
+ -Dselinux="$(usex selinux true false)"
+ -Dtests="$(usex test true false)"
+ -Dudev="$(usex udev true false)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}
diff --git a/net-misc/casync/metadata.xml b/net-misc/casync/metadata.xml
new file mode 100644
index 000000000000..b5956467d232
--- /dev/null
+++ b/net-misc/casync/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <use>
+ <flag name="fuse">Enable fuse support</flag>
+ <flag name="man">Build and install man pages</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">systemd/casync</remote-id>
+ </upstream>
+</pkgmetadata>